All users were logged out of Bugzilla on October 13th, 2018

[1.4] There should not show "sending" dialog when dialing USSD code without sim card inside.

RESOLVED INVALID

Status

RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: wei.gao, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
OS version
---------------------------------------------
FireFoxOS v1.3t v1.4

Reproduce steps:
---------------------------------------------
Dial USSD code like "*...#" without sim card inside.

Actual result:
---------------------------------------------
show "sending" dialog 

Expected result:
---------------------------------------------
Should show emergency only dialog

Probability:
---------------------------------------------
Always Recurrence
(Reporter)

Comment 1

4 years ago
Created attachment 8439848 [details] [diff] [review]
detect_sim_state_before_dialing_USSD.patch

Hi Etienne

This is a patch for this on v1.4,
It will show emergency only dialog when dialing USSD code without sim card inside
Can it be granted?

Please help to review.
Thanks.
Flags: needinfo?(etienne)
Comment on attachment 8439848 [details] [diff] [review]
detect_sim_state_before_dialing_USSD.patch

mmi, redirecting to Rik
Attachment #8439848 - Flags: review?(anthony)
Flags: needinfo?(etienne)
Comment on attachment 8439848 [details] [diff] [review]
detect_sim_state_before_dialing_USSD.patch

Review of attachment 8439848 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for that patch. I'd like some context: You mention it's a patch for 1.4 but right now, even if I see the sending dialog, I see a "generic failure" screen after. Not the nicest error message but I don't think this is bad enough to justify a 1.4-only patch. Am I missing a detail?

This is duplicating the code that displays error messages. I'd rather not do that. Also, we'll get good error handling for free once bug 889737 lands.
Attachment #8439848 - Flags: review?(anthony)
(Reporter)

Comment 4

4 years ago
(In reply to Anthony Ricaud (:rik) from comment #3)
> Comment on attachment 8439848 [details] [diff] [review]
> detect_sim_state_before_dialing_USSD.patch
> 
> Review of attachment 8439848 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Thanks for that patch. I'd like some context: You mention it's a patch for
> 1.4 but right now, even if I see the sending dialog, I see a "generic
> failure" screen after. Not the nicest error message but I don't think this
> is bad enough to justify a 1.4-only patch. Am I missing a detail?
> 
> This is duplicating the code that displays error messages. I'd rather not do
> that. Also, we'll get good error handling for free once bug 889737 lands.

Sorry, because there is no "generic failure" screen show, I check the code again and find that's a bug of dolphin(sprd7715). After execute "_conn.sendMMI(message)" without sim card inside, it return "onsuccess", so that should be resolved by our sprd.

Thanks.
Cool ! Can we close this bug then? (and wait for bug 889737 to get the nicer UI)
Flags: needinfo?(wei.gao)
(Reporter)

Comment 6

4 years ago
(In reply to Anthony Ricaud (:rik) from comment #5)
> Cool ! Can we close this bug then? (and wait for bug 889737 to get the nicer
> UI)

Hi Anthony

Thanks for your attention.
Let's close it, and sorry to trouble you.
Bye the way, How can i close this bug?
Thanks.
Flags: needinfo?(wei.gao)
No problem.

To close a bug, change its status to RESOLVED. And then choose a resolution. This one was INVALID.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
(Reporter)

Comment 8

4 years ago
(In reply to Anthony Ricaud (:rik) from comment #7)
> No problem.
> 
> To close a bug, change its status to RESOLVED. And then choose a resolution.
> This one was INVALID.

Thank you very much.
You need to log in before you can comment on or make changes to this bug.