Uplift recent PSL changes to Firefox 31 and 32

VERIFIED FIXED in Firefox 31

Status

()

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: gerv, Assigned: gerv)

Tracking

31 Branch
Firefox 31
Points:
---

Firefox Tracking Flags

(firefox31+ verified, firefox32+ verified, firefox33 verified, firefox-esr24 fixed)

Details

Attachments

(1 attachment)

We recently made two large batches of changes to the Public Suffix List, clearing a several-month backlog. These changes included a change for .uk to reflect the fact that they have now gone live with top-level registration. .uk is a busy TLD, and errors here will get noticed. The impact if the uplift doesn't happen is that sites using the new wibble.uk domain names may not be able to set cookies across their multiple servers. 

We should uplift the current PSL file en masse to Firefox 31 (beta) and 32 (aurora). (Let me know if you need two separate bugs for this.) The file is known to pass tests on mozilla-central and so the risk is minimal.

Here's the .uk change:
https://hg.mozilla.org/mozilla-central/rev/8597415940ed
although I'd want to take the file wholesale, including all the updates.

Gerv
Why do you open a new bug for this? bug 1015214 is a better place for an uplift request.
Flags: needinfo?(gerv)
Bug 1015214 only covers the .uk changes. As I said, I want to upload all the recent changes, which are about 15 bugs.

I will attach a patch or patches in a moment.

Gerv
Flags: needinfo?(gerv)
Posted patch Patch v.1Splinter Review
This patch contains all the recent PSL changes, and applies to both mozilla-aurora and mozilla-beta. It makes the PSL the same on those branches as it is on mozilla-central.

Gerv
Assignee: nobody → gerv
Status: NEW → ASSIGNED
Attachment #8439888 - Flags: review+
Comment on attachment 8439888 [details] [diff] [review]
Patch v.1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Rollup patch for 17 bugs, listed here: https://bugzilla.mozilla.org/buglist.cgi?resolution=FIXED&chfieldto=2014-06-13&chfield=bug_status&chfieldfrom=2014-06-08&component=Networking%3A%20Domain%20Lists

User impact if declined: problems with PSL-related functionality, including cookie-setting, on various domains, including the new wibble.uk domains. If patch is not taken, problems will persist for 12 weeks longer than otherwise.

Testing completed (on m-c, etc.): Passes all tests on m-c. 

Risk to taking this patch (and alternatives if risky): Very low.

String or IDL/UUID changes made by this patch: none.

Gerv
Attachment #8439888 - Flags: approval-mozilla-beta?
Attachment #8439888 - Flags: approval-mozilla-aurora?
Comment on attachment 8439888 [details] [diff] [review]
Patch v.1

31 will be an ESR. Taking it for this release.
Attachment #8439888 - Flags: approval-mozilla-beta?
Attachment #8439888 - Flags: approval-mozilla-beta+
Attachment #8439888 - Flags: approval-mozilla-aurora?
Attachment #8439888 - Flags: approval-mozilla-aurora+
Flagging for verification to keep an eye out for potentially broken websites due to this change.
Keywords: verifyme
Should we uplift this to 24 seeing as we'll still be supporting it for a while after 31 gets out, if I understand our ESR policy correctly?
Flags: needinfo?(gerv)
I have no objections. But I don't think we'd ship just for this. Do we plan another point release?

Gerv
Flags: needinfo?(gerv)
We release in parallel of the release version. So, in about 2 weeks.
See: https://www.mozilla.org/en-US/firefox/organizations/faq/
(In reply to Gervase Markham [:gerv] from comment #9)
> I have no objections. But I don't think we'd ship just for this. Do we plan
> another point release?
> 
> Gerv

Yes, apparently: http://www.mozilla.org/en-US/firefox/organizations/faq/

Can you handle the approval request and/or check that the patch applies cleanly? :-)
Verified fixed on Firefox 31 Beta 8 (Build ID: 20140707160635), Windows 7 64-bit, using several newly added/removed domains. Monitored the Network:Cookies panel and the Browser Console's output for potential issues. Further details can be found in this etherpad [1].

Gerv, if there's anything else we should look at here, please let me know.


[1] https://etherpad.mozilla.org/PSL-Fx31
No, that sounds great. Thanks!

Gerv
(In reply to Gervase Markham [:gerv] from comment #14)
> No, that sounds great. Thanks!
> 
> Gerv

Thank you for confirming. I'm going to mark this issue verified fixed and follow up with my results from Aurora 32 and Nightly 33 as soon as possible.
Status: RESOLVED → VERIFIED
Verified fixed on Aurora 32.0a2 2014-07-08 (Build ID: 20140708004001) and Nightly 33.0a1 2014-07-08 (Build ID: 20140708030203) as well. Updated the etherpad from Comment 13 with detailed results.
If this is to get on ESR24 we'll need a nomination asap (and make sure it applies to that branch).
Flags: needinfo?(gerv)
Lukas: it went on to ESR 24 in bug 1033340.

Gerv
Flags: needinfo?(gerv)
You need to log in before you can comment on or make changes to this bug.