Closed Bug 1024971 Opened 6 years ago Closed 6 years ago

Location is not displayed after creating a new profile

Categories

(Participation Infrastructure :: Phonebook, defect)

2014-06.1
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: williamr, Assigned: giorgos)

References

(Blocks 1 open bug)

Details

(Whiteboard: [kb=1409098] )

Attachments

(1 file)

I am filling this bug for Rosana after watching her test the new geolocation functionality.

Steps to reproduce:
1. Login with an email address that is not already associated with an email address on the stage server
2. Create a new profile that has location values for city / region / country
3. View profile and check if location values are displayed
4. Edit profile and check if location values are displayed

Expected behavior:
Location values are displayed both when viewing or editing the profile.

Actual behavior:
Location values are _not_ displayed when viewing profile. Location values are shown when _editing_ the profile.

See https://mozillians.allizom.org/en-US/u/rardila/
Nice catch William, I'm on it.
Assignee: nobody → giorgos
Status: NEW → ASSIGNED
Whiteboard: [kb=1409098]
Commits pushed to master at https://github.com/mozilla/mozillians

https://github.com/mozilla/mozillians/commit/ac61546ea6f534027bfa046c901df25ac9ef5688
[fix bug 1024971] Display new geolocation fields on profile page for new profiles.

https://github.com/mozilla/mozillians/commit/dd3536d0a66a0b60bbca674cf254af5e3a4d9bb0
Merge pull request #971 from glogiotatidis/1024971

[fix bug 1024971] Display new geolocation fields on profile page for profiles.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Version: other → next
Blocks: 920651
I followed William's steps and I can reproduce this bug using an unvouched profile. Location info only visible when editing a profile.
Which env [dev or stage] did you test this on?
Flags: needinfo?(terrameijar)
O, I should have been more specific, I tested this on stage.
Flags: needinfo?(terrameijar)
Attached image qa - verified on stage
terrameijar, Curious -- I cannot reproduce the behavior you're seeing. Per the STR in comment 0 this appears fixed on stage.

- create new account 
- set location when creating the new profile
- save profile
- view profile and ensure location has been saved.

Bumping to QA verified -- please reopen/file a new bug if you can reproduce the behavior
Status: RESOLVED → VERIFIED
Version: next → 2014-06.1
You need to log in before you can comment on or make changes to this bug.