Update design for Hive Community Member Badge

RESOLVED FIXED

Status

Webmaker
Hive
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: omnignorant, Assigned: omnignorant)

Tracking

Details

(Whiteboard: [badges][june27], URL)

Attachments

(4 attachments)

(Assignee)

Description

3 years ago
Created attachment 8439989 [details]
Hive Community Badge Icon

1. The badge name should be "Hive Community Member"

2. Please use the attached image for the badge icon

3. Add the following tags: Hive, Hive Global, Hive Learning Network

4. Add the following language somewhere clearly visible on the page (above the criteria is preferred): "Applicants must provide evidence that satisfies 2 out of the 3 numbered criteria below/above."

5. Under criteria #1 "Peer Observation" change "Attending and observing Hive member programs;" to "Attending and observing Hive member programs: club meetings, maker parties, showcases, career days, drop-in hours, etc." (feel free to drop/edit an example to keep it to one line).

6. Under criteria #1 "Peer Observation" add the following 4th bullet: "Run a station at a collaborative event like a pop-up/maker party or at another member organization;"

7. Under criteria #2. Resource Sharing Change: "Making your personal contact and affiliation accessible to Hive members;" to "Making your personal contact and affiliation accessible to Hive members and respond to a request for assistance;"

8. Under criteria #3. Process Documentation, adjust the heading subtext: "Documenting and sharing ...but is not limited to:" so that the font is italicized (right now there are leading/trailing underscores).
Robert, can you get a high-resolution version of that image?

It needs to be minimum 440x440px and have a transparent background.
The svg/eps/illustrator file would be fine too
Also there should be no empty around the badge itself
(Assignee)

Comment 4

3 years ago
Julia, we need a high-resolution version of the badge image: It needs to be minimum 440x440px and have a transparent background and there should be no empty around the badge itself. The svg/eps/illustrator file would be fine too.

I didn't know these details, but Kate has just requested it! Needs to happen STAT for launch EOD today.
Flags: needinfo?(julia)

Comment 5

3 years ago
Created attachment 8440043 [details]
Hive-Community-Badge-Final.png

Here is the the final design. It is 500x500 pixels with no background. I also attached the ai file just in case.
Flags: needinfo?(julia)

Comment 6

3 years ago
Created attachment 8440044 [details]
Hive Community Member Badge_Final.ai

ai file for badge
(Assignee)

Comment 7

3 years ago
Thank you Julia!!! You are a wizard.

Comment 8

3 years ago
you bet! let me know if anything needs to happen for it.
Status: NEW → ASSIGNED
Summary: Changes to Hive Community Member Badge to make the move from mofostaging to webmaker.org → Update design for Hive Community Member Badge
(Assignee)

Comment 9

3 years ago
Eek, I noticed two more items:

9. Under Criteria #2: "Resource Sharing" subtext, change: "Clearly articulating resources you or your organization can share with the network." to "Clearly articulating resources you or your organization can share with a Hive Network."

10. Under Criteria #3: "Process Documentation" subtext, change: "Documenting and sharing useful processes for others to use or remix." to "Documenting and sharing useful processes for others in a Hive Network to use or remix."
@ Robert: who do you want to make those changes?

* I believe you can log into BadgeKit and make the changes yourself. 

* Kate: does Rob have the credentials to do that?
Flags: needinfo?(kate)
(Assignee)

Comment 11

3 years ago
and yet, two more items (ugh, don't kill me!)

11. Can we please add a link to the wiki https://wiki.mozilla.org/Webmaker/Hive/Hive_Community_Member_Badges for more information about this badge? i.e. "For more information about this badge and the criteria below, click here."

12. The issuing URL should be http://hivelearningnetworks.org, Lainie said that is launching very soon and the URL already seems to belong to us, so there's no harm of it pointing at the wrong place.
(Assignee)

Comment 12

3 years ago
Matt, I already checked in with Kate via email.
Awesome, I'll update this.

:openmatt unfortunately badgekit does not allow editing, so I have to do it manually in the DB
Flags: needinfo?(kate)
(Assignee)

Comment 14

3 years ago
Kate, thanks so much for tackling this! You rock! Let me know if you need anything more from me.
Whiteboard: [hivebadges][june13] → [hivebadges][june27]
Hey robert, we can't really add extra text like: 

4. Add the following language somewhere clearly visible on the page (above the criteria is preferred): "Applicants must provide evidence that satisfies 2 out of the 3 numbered criteria below/above."

We could add it to the general badge description.

That said, we no longer require super mentors/mentors/admins to check satisfied for each criteria -- it's a subjective process. Would it be ok if we left that out?
(Assignee)

Comment 16

3 years ago
Per #4. We need something to signal to our applicants what they need to do to successfully earn this badge. We've decided that it is 2 of 3. Please add it to the general badge description if that is the only option. In which case, you can drop the "above/below" text if that is something layout dependent and shouldn't travel with the meta data.

And thank you again!
Whiteboard: [hivebadges][june27] → [badges][june27]
* Robert: can you update the badge description in BadgeKit?
Assignee: kate → robert
(Assignee)

Comment 18

3 years ago
no, a dev has to do it now.
Ok, updating now
Ok, added those last changes. Can you review and mark the ticket as resolved if everything looks good?
(Assignee)

Comment 21

3 years ago
Hey Kate! Sorry that this is so cray. Hopefully we will avoid this back and forth in the future by nailing the badges before we publish. Chalk this one up to our first time at bat.

* In the description, replace the http://hivelearningnetworks.org link with the wiki https://wiki.mozilla.org/Webmaker/Hive/Hive_Community_Member_Badges and can we make that a link (not the whole url) i.e. "See our wiki (<-link) for more information about this badge and the criteria below."

* The issuing URL should be http://hivelearningnetworks.org (plural networks, not singular)

* Add the following tags: Hive, Hive Global, Hive Learning Network

Thank you, thank you, thank you.
There's overlap here with this one: https://bugzilla.mozilla.org/show_bug.cgi?id=1026160
Marking that one a dupe.

* Let's do this all in one go. Final changes needed:



1) Add the tags: Hive, Hive Global, Hive Learning Network

2) Add this to badge description: "Applicants must provide evidence that satisfies two out of the three numbered criteria."

3) Change issuing URL to http://hivelearningnetworks.org

4) Replace the http://hivelearningnetworks.org link with wiki https://wiki.mozilla.org/Webmaker/Hive/Hive_Community_Member_Badges 

like this:

[See our wiki] for more information about this badge and the criteria below. (https://wiki.mozilla.org/Webmaker/Hive/Hive_Community_Member_Badges)
Duplicate of this bug: 1026160
(Assignee)

Comment 24

3 years ago
Yeppers. I think Kate already did item 2.
I've changed the issuer url of the badge and added the three tags you mentioned.  The line about applicants needing to provide evidence was already in the description, although I changed it to spell out "two" and "three" rather than using numerals.

Now, the tags will not show up yet, because it looks like there is a line of code hard-coding those tags into every badge (presumably because tags didn't yet exist in badgekit).  I'll submit a PR removing these hard-coded tags soon, although be aware that this will remove tags from every badge on your site that doesn't already have tags.  I've gone ahead and added the hard-coded tags to the actual badgekit database for the supermentor badge, but if different ones are desired, let me know.

Robert, to clarify, should the existing tags remain as well?  For now, they are still there for the Hive Community Member badge, but let me know if they should be removed.
Flags: needinfo?(robert)
(Assignee)

Comment 26

3 years ago
Um, most of that was a wash for me... but sounds like you're on it!

I think contributor, mozilla and community should stay. mentor and supermentor should go and be replaced by the tags below. Actually, just make it one tag "Hive Learning Networks". We don't need all three.
Flags: needinfo?(robert)
Created attachment 8442354 [details] [review]
https://github.com/mozilla/webmaker.org/pull/819

It's not totally impossible that I'm submitting this PR correctly.
Attachment #8442354 - Flags: review?(kate)
Somewhat arbitrarily flagged kate for the review of that change, but anyone can feel free to take it instead.  It's quite wee.
Comment on attachment 8442354 [details] [review]
https://github.com/mozilla/webmaker.org/pull/819

nice
Attachment #8442354 - Flags: review?(kate) → review+

Comment 30

3 years ago
Commit pushed to master at https://github.com/mozilla/webmaker.org

https://github.com/mozilla/webmaker.org/commit/0ea4a6fa4944b4098b25672a9ed6b3e8748e0d70
Merge pull request #819 from christensenep/1025092

Fixes bug 1025092 - Remove hardcoded badge tags
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.