Closed Bug 1025136 Opened 6 years ago Closed 5 years ago

[Geolocation] Cluj-Napoca is not found in the search field

Categories

(Participation Infrastructure :: Phonebook, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1134156

People

(Reporter: chiorean.ioana, Assigned: chiorean.ioana)

References

Details

Attachments

(1 file)

Attached image Screenshot
Steps:
1. Goto the search field
2. Type in Cluj-Napoca (Romania)
OSM: http://www.openstreetmap.org/node/32591050#map=11/46.7693/23.5901

ER: 
- Cluj-Napoca shoud be shown as a suggestion

AR:
- Cluj-Napoca it is not shown as a suggestion
OS: Mac OS X → All
Hardware: x86 → All
Just make an account on Open Street Maps
https://www.openstreetmap.org/user/new

Here's the duplicate of Cluj-Napoca. With a free account you can delete this whole city all by yourself!
http://www.openstreetmap.org/edit?editor=id&node=32591050#map=18/46.76939/23.59023

But first probably migrate all that useful data into this one.
http://www.openstreetmap.org/relation/3277038

and then proceed beyond! Fix more things!

Ioana, there are more map errors than you could ever dream of all around the world.
http://keepright.at/report_map.php?zoom=14&lat=48.20808&lon=16.37221

And you can fix them!
https://www.youtube.com/watch?v=8MF4oJIHuQw
Ioana,

Thanks for filing this bug. We are using mapbox.com which is based on OpenStreetMap data to turn lat, lon to placenames. So this is not something we can directly fix on mozillians.org.

The good news is that in true open source spirit, the results come from a public resource that we can also help to improve.

Wray provides a few good links and pointers on how you can fix this yourself. Are you interested to fix OSM data so we can verify that the changes are reflected in mozillians.org?
Flags: needinfo?(chiorean.ioana)
Summary: [Geolocation] Cluj-Napoca is not found n the search field → [Geolocation] Cluj-Napoca is not found in the search field
See Also: → 1025141
See Also: → 1025132
Thanks guys,
I do have an OSM account and I can edit this. I filled the bug knowing it is a 3rdparty issue to be tracked and known.

I will be back with an update when I've edited the OSM.
Assignee: nobody → chiorean.ioana
Flags: needinfo?(chiorean.ioana)
OSM also has a feature called "Notes" which is their easy way of reporting a problem for someone else to fix. We were considering linking to https://wiki.openstreetmap.org/wiki/Notes for future questions about this sort of thing. Would you agree that's a good route, Ioana? I think we're the only two that bothered to sign up for OSM accounts and are getting our hands dirty with how they handle errors. It would be good to get your input now that you've tried your hand at it, too.
(In reply to Ioana Chiorean from comment #3)
> I will be back with an update when I've edited the OSM.

Any updates on this Ioana?
Flags: needinfo?(chiorean.ioana)
sorry for late reply here Giorgos but.. 
I took the advices in Comment 1 and I got stock as on OSM the Cluj result is ok or at least I understood it like that. . 

I've contacted Nikos Roussous who has more experience than myself and got this:
====================================================
OpenStreetMap geocoding corretly returns Cluj-Napoca as an option when searching for Cluj:
http://nominatim.openstreetmap.org/search?q=cluj&format=json

While Mapbox's geocoding service returns only the province:
https://api.tiles.mapbox.com/v3/mozilla-webprod.i81ph114/geocode/cluj.json

I don't know if there is much you can do. Mapbox has its own geocoding service that uses a subset of OpenStreetMap's one.
https://www.mapbox.com/help/geocoding-api/

It should include Cluj-Napoca (since it is a city :P), but apparently it doesn't. Even when creating a map thought its web app.
http://i.imgur.com/c7oIJ5m.jpg

So no edit on OpenStreetMap can fix this 
=============================================================
So I am now investigating the mapbox - if I can add a new bug.
Flags: needinfo?(chiorean.ioana)
I sent an email at Mapbox support about their geocoding service, using Cluj as an example. I'll update when they answer.
Update from Mapbox:
https://github.com/mapbox/carmen/issues/141
It seems that currently it uses Flickr places instead of OpenStreetMap for Geocoding, but this is about to change. I guess not many geotagged photos at Cluj-Napoca.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1134156
You need to log in before you can comment on or make changes to this bug.