enable geo-map mouse scroll zoom

VERIFIED WONTFIX

Status

Participation Infrastructure
Phonebook
VERIFIED WONTFIX
4 years ago
4 years ago

People

(Reporter: athulsuresh, Assigned: wbowling)

Tracking

Details

(Whiteboard: [kb=1414808] )

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.153 Safari/537.36

Steps to reproduce:

Make a new profile or Edit the profile.


Actual results:

Map doesn't have mouse scroll zoom option


Expected results:

Having Mouse Scroll zoom in maps is a proven UX technique.

Updated

4 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: 2014-06.6 → next
(Assignee)

Updated

4 years ago
Assignee: nobody → wbowling
Whiteboard: [kb=1414808]
Not sure we should fix this -- I removed this feature because it has a bad side effect -- The problem is that when you edit profile, and try to scroll down, you'll immediately get stuck in the map and zoom scroll it, and then you'll have to move your mouse pointer away from there to scroll further down the page. This sucks if you are editing anything other than your location, which most people will edit rarely, and you can zoom in and out with the +/- buttons and with double click if you need to.

Unless there's some way to fix it so that the map never acquires scrolling focus unless you click on it first, I don't think we should fix this.
(Assignee)

Comment 3

4 years ago
I tend to agree with Andrei. The primary interaction we're expecting is search, and once you're done locating yourself, just move on. The visualization maps on the other hand *will have mouse wheel scrolling* because it's interesting to look at.

But hey... the pull request is there if you can talk more about why you feel it's necessary, :athulsuresh. I too, always feel awkward when there's a map with scrollwheel zooming disabled. It usually makes sense after thinking about what the map's purpose is though.
Flags: needinfo?(atulsuresh123)
(Reporter)

Comment 4

4 years ago
Well, to the point Andrei made it seems not having the autoscroll is good. But still the problem with the button zoom is that it uses the map pointer as the reference point/pivot. For the autoscroll the mouse pointer is used as the pivot for the zoom. To select remote places it's pretty hard as of now i guess.
Flags: needinfo?(atulsuresh123)
I am going to close this based on comment 2 and 4. While the idea of autoscroll is good, it has a bad side of preventing a user from scrolling down the page. Too bad we can't easily support it and have a good user experience.

Please reopen if there are other solutions to consider.

Athul, thanks for filing this great bug! Keep the bugs coming :)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
Bumping to qa verified wontfix per comment 5
Status: RESOLVED → VERIFIED
Version: next → other
You need to log in before you can comment on or make changes to this bug.