NullPointerException while loading ICQ Lite

VERIFIED FIXED

Status

Core Graveyard
Java: OJI
--
major
VERIFIED FIXED
17 years ago
8 years ago

People

(Reporter: Marcus Brito, Assigned: edburns)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20010913
BuildID:    2001091311

When trying to access the ICQ Lite, nothing happens. Taking a peek at
plugin_stack.trace on my home directory, I found a NullPointerException. Here's
the error:

java.lang.NullPointerException
	HAE_GetSupportedCaptureFormats could not get pseudoDevice
at Start.init(Unknown Source)
	at sun.applet.AppletPanel.run(AppletPanel.java:348)
	at sun.plugin.navig.motif.MotifAppletViewer.maf_run(MotifAppletViewer.java:127)
	at sun.plugin.navig.motif.MotifAppletViewer.run(MotifAppletViewer.java:123)
	at java.lang.Thread.run(Thread.java:498)

The following also appeared on stdout:
HAE_GetSupportedCaptureFormats could not get pseudoDevice

May be the problem is applet-specific. Well, the applet worked fine on IE and
other browsers, and also worked OK on 0.9.3

Reproducible: Always
Steps to Reproduce:
1. Access http://www.icq.com/icqwebbie
2. Click the "Start ICQ Lite button"


Actual Results:  A pop-up window should appear, and nothing else happens

Expected Results:  A pop-up window should have appeared, and the ICQ Lite applet
should have loaded on that window.
Works for me using Mozilla nightly build 2001103108

Could you please try again with a newer version of Mozilla?
(Reporter)

Comment 2

17 years ago
I've recently tried to use the applet again with Mozilla 0.9.5, and everything
seems fine now. The bug is fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 3

17 years ago
Verified on linux (trunk build; 2001-11-20-08-trunk).
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.