[GTK system fonts]Some fonts are too small on Linux

RESOLVED INVALID

Status

()

--
major
RESOLVED INVALID
18 years ago
17 years ago

People

(Reporter: jjkarppi, Assigned: dbaron)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
Since build 20010928 some fonts (such as in menubar, personal toolbar, and
forms) are significantly smaller than before. Look at the screenshots to see
what I mean. Some people might like it better this way, but I think there should
at least be a preference to easily adjust the size.

I tried to change this in  Edit/Preferences/Appearence/Fonts by raising the
"display resolution", but that helped only temporarily. On next startup the
fonts were small again. (Besides, it's rather clumsy now, because you can't
directly give an arbitrary dpi value.)

This was perhaps caused by fix to bug 99010; that landed in 20010928, and in
20010927 the fonts were still normal. And btw, I didn't see this occur on w2k,
so I guess it's linux only.
(Reporter)

Comment 1

18 years ago
Created attachment 51522 [details]
Mozilla 0.9.4 with "normal" fonts
(Reporter)

Comment 2

18 years ago
Created attachment 51524 [details]
Build 20010930 with much smaller fonts
I'm seeing this too, on 2001092906. Altering the display dpi doesn't seem to fix
this.

Comment 4

17 years ago
Looks like some minor fallout from the font work...
Assignee: attinasi → rbs
Out of curiosity, what does your .gtkrc say about font sizes?  Didn't the system
fonts stuff just land as well on Linux?

Comment 6

17 years ago
Since the dpi has no effect, maybe system fonts instead (bug 33313)?
Cc:ing dbaron.
(Reporter)

Comment 7

17 years ago
I don't really know about all those different gtkrc-files on my system, but,
using the Gnome Control Center I changed the font, and that did (after restart)
change the Mozilla fonts too!

Sorry about that, I didn't realise Mozilla used GTK+ for anything... 

I'll add yet another screenshot using Gnome's default theme and font. 
(Notice that, while other fonts are the same as in the first screenshot, the
status bar still has a slightly too small font, which is bit hard to read.)
(Reporter)

Comment 8

17 years ago
Created attachment 51566 [details]
20010930 using default GTK settings
(Reporter)

Comment 10

17 years ago
Oops.. there's nothing wrong with the Status Bar font (or any other font AFAIK)
now that I remembered to change the "Display resolution" preference back to
"System setting".

Comment 11

17 years ago
-> dbaron
Assignee: rbs → dbaron
Summary: Some fonts are too small on Linux → [GTK system fonts]Some fonts are too small on Linux

Comment 12

17 years ago
Judging by reporters last screenshot and comment, it sounds like this is a
"works for me"? (Works-for-me too, btw., current CVS and earlyer.)
(Reporter)

Comment 13

17 years ago
Yeah, this bug is not valid.

(The only issue here could be that perhaps I'm not the only one who didn't 
know that GTK-settings affect Mozilla. Maybe it should be pointed out more 
clearly somewhere?)

Yeah. We should relnote this.  I'll mail Dawn.

Marking invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
Well, there were two legitimate bugs here:
 1) changing display resolution somehow does affect system fonts (perhaps since
they've already been copied into the rule tree)
 2) the statusbar text starts with a system font and makes it smaller, which is
bad.  They should probably start with a different system font...
Filed bug 105551 on the statusbar.  I couldn't figure out how to get changing
the dpi to influence system fonts.  If you have steps to reproduce, could you
file a bug?
You need to log in before you can comment on or make changes to this bug.