Last Comment Bug 102543 - Cannot decode all recipients in CMS structure.
: Cannot decode all recipients in CMS structure.
Status: RESOLVED FIXED
:
Product: NSS
Classification: Components
Component: Libraries (show other bugs)
: 3.3.1
: All All
: P1 normal (vote)
: 3.3.2
Assigned To: Robert Relyea
: Sonja Mirtitsch
Mentors:
: 115275 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-01 10:52 PDT by David P. Drinan
Modified: 2001-12-17 14:06 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Patch for review. (551 bytes, patch)
2001-10-01 10:55 PDT, David P. Drinan
no flags Details | Diff | Splinter Review

Description David P. Drinan 2001-10-01 10:52:16 PDT
The ASN.1 libraries will not decode all the recipients in the RecipientInfo
field of the Cryptographic Message Syntax (CMS) structure. Only the first
recipient is decoded.
Comment 1 David P. Drinan 2001-10-01 10:55:30 PDT
Created attachment 51536 [details] [diff] [review]
Patch for review.
Comment 2 David P. Drinan 2001-10-01 10:57:30 PDT
The above patch is what Terry Hayes came up with after we debugged the ASN1 decoder.
Comment 3 Wan-Teh Chang 2001-10-01 14:57:27 PDT
Bob, could you review this patch?

Should we check it in on the NSS_3_3_BRANCH (after
NSS 3.3.1 is released)?
Comment 4 Robert Relyea 2001-10-03 09:09:40 PDT
r=relyea

Yes, I think we should put the change in the 3.3 Branch, though I don't
anticipate a 3.3.2 release.

bob 
Comment 5 Wan-Teh Chang 2001-10-31 18:07:48 PST
David,  I believe you checked in this fix on the
NSS_3_3_BRANCH yesterday.  Correct?

Please mark this bug fixed after you check in the
fix on the tip of NSS.  Thanks.
Comment 6 Robert Relyea 2001-11-28 15:19:26 PST
Verified that the fix has been checked into 3.3
Comment 7 Wan-Teh Chang 2001-12-17 14:06:07 PST
*** Bug 115275 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.