bg / Bulgarian language package corrupt error

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: toadyshadow101, Assigned: ogi)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 20140612184002

Steps to reproduce:

Try to download & install bg/ Bulgarian language pack
ftp://ftp.mozilla.org/pub/firefox/releases/30.0/win32/xpi/bg.xpi

Affects: 24-31


Actual results:

Throws error:

The add-on downloaded from ftp.mozilla.org could not be installed because it appears to be corrupt.

Learn more....



Expected results:

The language pack should install without error.

Solution: remove white-space from top of install.rdf above <?xml version="1.0"?>
pack then installs correctly without error.
(Reporter)

Updated

5 years ago

Updated

4 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

4 years ago
Duplicate of this bug: 1069814
(Reporter)

Comment 2

4 years ago
Hello,

This issue is still present on current release
[App]
Vendor=Mozilla
Name=Firefox
RemotingName=firefox
Version=35.0
BuildID=20150108202552
SourceRepository=https://hg.mozilla.org/releases/mozilla-release
SourceStamp=32e36869f84a
ID={ec8030f7-c20a-464f-9b0e-13a3a9e97384}

Test URL: ftp://ftp.mozilla.org/pub/firefox/releases/35.0/win32/xpi/bg.xpi

Current beta also 

[App]
Vendor=Mozilla
Name=Firefox
RemotingName=firefox
Version=36.0
BuildID=20150120155007
SourceRepository=https://hg.mozilla.org/releases/mozilla-beta
SourceStamp=ddf243cd8f14
ID={ec8030f7-c20a-464f-9b0e-13a3a9e97384}


Test URL: ftp://ftp.mozilla.org/pub/firefox/releases/36.0b3/win32/xpi/bg.xpi

White space above <?xml version="1.0"?> is still present causing the addon to throw error of being corrupt when trying to install it.
I think it is either a duplicate or depends on bug 832060, marking as a dependency for now. Pike can you check if this is a dupe or not? Thanks
Depends on: 832060
Flags: needinfo?(pascalc)

Updated

4 years ago
Flags: needinfo?(pascalc) → needinfo?(l10n)

Comment 4

4 years ago
We're fixing this for beta and roll out the fix with 36. I've done a sign-off after a technical review, and given the relatively small updates to the actual translation, taking the fix for this technical problem looks like a good balance.

We're taking more updates as part of that, though we'd really like to get an honest translation update for Firefox again, too.

Removing bug 832060, 'cause it'd be nice to have that one fixed, but it's not related to the fix we're using.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
No longer depends on: 832060
Flags: needinfo?(l10n)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.