bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Market place facebook app not updated with the latest version

REOPENED
Unassigned

Status

Tech Evangelism
Preinstalled B2G Apps
REOPENED
4 years ago
4 years ago

People

(Reporter: dvigneshwer, Unassigned, NeedInfo)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8440247 [details]
UI of fb app is not latest

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140506152807

Steps to reproduce:

steps 

1.install Facebook app from the marketplace 

2.In tablet i was not getting the current version as in Facebook , please refer to the image.




Actual results:

Facebook app was not latest and its actual UI was not loading


Expected results:

it should be playing the latest fb mobile as available in other platforms
CCing Thomas for the feedback here, but wontfixing this bug as it's not a Marketplace bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
Can you reply back what the Tablet's User Agent is? It looks like the User agent above is for your Desktop machine.

I think this is related to a fix FB recently pushed for Tarako.

https://bugzilla.mozilla.org/show_bug.cgi?id=1007019
Status: RESOLVED → REOPENED
Component: General → Preinstalled B2G Apps
Ever confirmed: true
Flags: needinfo?(dvigneshwer)
Product: Marketplace → Tech Evangelism
Resolution: INVALID → ---
Version: 1.4 → unspecified

Updated

4 years ago
Blocks: 759986

Comment 3

4 years ago
Hi,

It is the expected behavior, that lo-fi Facebook is loaded when you go to m.facebook.com from your desktop Firefox browser. So if the UA string of the device is indicative of a Firefox desktop browser, then this is expected.
The expectation here is that the desktop version is served for tablets. This will be a re-occurring theme with apps as most of them submitted their m. site which will not work great on tablets.
You need to log in before you can comment on or make changes to this bug.