CSS2 A:hover fails to activate unless explicitly placed after A:link

VERIFIED INVALID

Status

Tech Evangelism Graveyard
English US
VERIFIED INVALID
17 years ago
3 years ago

People

(Reporter: Michael Dunn, Assigned: bc)

Tracking

Details

(Whiteboard: [XBROWSER-CSS], URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
CSS2 A:hover fails to activate unless explicitly placed after A:link
 
W3C does indicate A:hover must be placed after the A:link, but if listed alone
one should expect the rule to apply after the page defaults.
If the default color for a unvisited links is blue then invoking the following
should equate to the same behavior:
 
   A:link { color: blue } /* unvisited links */
   A:hover { color: red } /* makes url links turn red when rolled over */
 
as A:hover with no other link rules listed
 
A:hover { color: red } /* makes url links turn red when rolled over */
 
This is the manner in which IE works.

I know there are already several hover related bugs in bugzilla and this might
likely prove a duplicate of one of those like bug 52766.
(Reporter)

Comment 1

17 years ago
Created attachment 51542 [details]
A:hover failure test case
(Reporter)

Updated

17 years ago
Keywords: topembed

Comment 2

17 years ago
Testcase works for me (rolls over to red on hover) using 20010928 nightly on Win2K.
Evangelism.  The _external_ style sheet has:

<STYLE TYPE="text/css">
<!--
a:hover { color: red } /* makes url links turn red when rolled over */


The invalid HTML markup (not allowed in external sheets) causes that first rule
to be ignored.
Assignee: joki → bclary
Component: Event Handling → English: US
Keywords: topembed
OS: Windows 2000 → All
Product: Browser → Tech Evangelism
QA Contact: madhur → zach
Hardware: PC → All
Whiteboard: [XBROWSER-CSS]
Version: other → unspecified
(Reporter)

Comment 4

17 years ago
You are absolutely correct that the test case works as expected, after
retesting. Unfortunately I must have gotten my browser in an unknown state where
the failure seemed apparent. Closing and pushing back to bugscape for Evang.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 5

16 years ago
Verified
2002040608/WinXP
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.