Translation feature does not work at all

RESOLVED INVALID

Status

()

RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: soeren.hentzschel, Unassigned)

Tracking

Trunk
All
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Bug 1021921 suggests the launch of a pre-trial of instant translation for users of the German Aurora version. So I wanted to test the new feature. I tested with Firefox Nightly, Firefox Aurora (en-US) and Firefox Aurora (de) with new profiles on more than ten websites - all without success.

I set browser.translation.ui.show and browser.translation.detectLanguage to true and restarted my browser. I visited a few websites with English content. There appeared the translation bar, I clicked the "translate" button, but after a short time the translation bar says: "There has been an error translating this page". On every website the same.

The browser console says after the start of the browser:

A promise chain failed to handle a rejection.
Full Message: TypeError: provider is null

(Translation.jsm:216)
(Reporter)

Updated

4 years ago
Summary: Translation feature is does not work at all → Translation feature does not work at all
Sorry, this feature is not yet directly testable on Nightly because to use the translation service it's necessary to have an api key for the service, and we don't have a mozilla-wide key yet.

If you want to test it, you can create one for yourself at Microsoft's website (here's a guide on how to do it: http://blogs.msdn.com/b/translation/p/gettingstarted1.aspx) and set it through the prefs
browser.translation.bing.clientIdOverride
browser.translation.bing.apiKeyOverride
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
Duplicate of this bug: 1041643
You need to log in before you can comment on or make changes to this bug.