Closed Bug 1025486 Opened 5 years ago Closed 5 years ago

No tab overflow arrows shown on overflow

Categories

(Thunderbird :: Toolbars and Tabs, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 33.0

People

(Reporter: Paenglab, Assigned: Paenglab)

References

Details

(Keywords: regression)

Attachments

(2 files, 1 obsolete file)

Since landing of bug 878020 the tab overflow arrows are no more shown.
Attached patch tabOverflow.patch (obsolete) — Splinter Review
This patch fixes the issue and adds the shadow like bug 878020 added on FX.

Blake, I hope it's okay to give you the review? Mike has a long queue and I don't know who else I should ask.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8440284 - Flags: ui-review?(bwinton)
Attachment #8440284 - Flags: review?(bwinton)
Comment on attachment 8440284 [details] [diff] [review]
tabOverflow.patch

Review of attachment 8440284 [details] [diff] [review]:
-----------------------------------------------------------------

I see the tab-overflow arrows, but I don't see the shadow…  So, ui-r+ for the arrows, and ui-r- for the shadow?  ;)
The code, on the other hand, looks good, so r=me.
(As a side note, I would totally believe that my not seeing the shadows is actually a problem on my end, so if you can post a screenshot (preferably on Mac), I'll switch the ui-r- to a ui-r+.)

Thanks,
Blake.
Attachment #8440284 - Flags: ui-review?(bwinton)
Attachment #8440284 - Flags: ui-review-
Attachment #8440284 - Flags: review?(bwinton)
Attachment #8440284 - Flags: review+
Attached image shadow.png
This is a screenshot of a try-build from a previous patch where the padding and margin-bottom wasn't correct.

I started a try build with the latest patch: https://tbpl.mozilla.org/?tree=Thunderbird-Try&rev=c0d93e10a8c2 when it's finished you can try this to check if the shadow works.
(Just a thought, do we need an @2x version for OS X Retina?)
FX has also none. If it had one I would also copied it. And I think a @2x isn't necessary as it's only a gradient with different alpha values.
It was my fault, wrong file name in CSS. This patch fixes it.
Attachment #8440284 - Attachment is obsolete: true
Attachment #8440339 - Flags: ui-review?(bwinton)
Attachment #8440339 - Flags: review+
Comment on attachment 8440339 [details] [diff] [review]
tabOverflow.patch

Perfect!  :)
Attachment #8440339 - Flags: ui-review?(bwinton) → ui-review+
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/e59d2f3f4322
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 33.0
Flags: in-testsuite-
You need to log in before you can comment on or make changes to this bug.