Closed Bug 1025555 Opened 6 years ago Closed 5 years ago

HTML5's <link /> Prefetch doesn't work when appended from DOM

Categories

(Core :: Networking, defect)

33 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 580313

People

(Reporter: TailsTheKitsune, Unassigned)

Details

(Keywords: testcase)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0 (Beta/Release)
Build ID: 20140614030205

Steps to reproduce:

Create a prefetch <link /> via DOM and append to <head>


Actual results:

Firefox does not prefetch file. See Network Monitor (Ctrl+Shift+I -> Network prior to loading). Upon manually retrieving file manually, HTTP Request headers confirm that file is not cached (no 'If-Modified Since' field). Lack of cache is also evident performance-wise when loading. Test Case attached.


Expected results:

File should be prefetched and displayed in Network Monitor with HTTP header 'X-moz: prefetch'.
Status: UNCONFIRMED → NEW
Component: Untriaged → Networking
Ever confirmed: true
Keywords: testcase
Product: Firefox → Core
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 580313
You need to log in before you can comment on or make changes to this bug.