[V2.1][Contacts] Import Contacts from Memory card hangs on contact 70 and does not import more

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Contacts
RESOLVED WONTFIX
4 years ago
4 months ago

People

(Reporter: Binyamin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.153 Safari/537.36

Steps to reproduce:

Contacts>Settings>Import Contacts>Memory card


Actual results:

Imported 70 from hundreds of contacts.


Expected results:

Import all contacts
(Reporter)

Updated

4 years ago
OS: All → Gonk (Firefox OS)
(In reply to Binyamin from comment #0)

Hi Binyamin, could you provide us with the phone used as well as the vcard file?
Requesting QAWANTED to check this.
Keywords: qawanted
(Reporter)

Comment 3

4 years ago
I use Geeksphone Peak device, the vcard contacts contains Unicode characters, English and Hebrew text.
Sorry, I do not feel comfortable to share with you my private vcard file.
(Reporter)

Comment 4

4 years ago
I just noticed the same bug also on Firefox OS v1.4, hangs on contact 70 and button "Cancel" and Home does not work - the only option is to restart the device.

Updated

4 years ago
QA Contact: ddixon
Branch Check 

Actual Results:   Contacts (at least 250) import from vCard/SD memory card correctly.

Issue DOES NOT occur in Flame 2.1, 2.0, 1.4 and 2.1 Buri builds.  


Device: Flame Master
Build ID: 20140804041427
Gaia: af9a0a24fb9f4c5ced3602bc14053bd49b136344
Gecko: 71497ed2e0db
Version: 34.0a1 (Master)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
-------------------------------------------------------------------------

Device: Flame 2.0
Build ID: 20140804060132
Gaia: 4ab7384db7aee130be165a699472cc19405a4456
Gecko: 5e94ab16ec71
Version: 32.0 (2.0)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
-------------------------------------------------------------------------

Device: Flame 1.4
Build ID: 20140801103150
Gaia: 8b476ef4cca719a2e90eb30fdcef0c3617cf574b
Gecko: 641db5b6540c
Version: 30.0 (1.4)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
-------------------------------------------------------------------------

Environmental Variables:
Device: Buri 1.4
Build ID: 20140617160225
Gaia: 3bdd037ec1a11abebe16a5d7f6ff0d863e80bc07
Gecko: 523491fa3339
Version: 30.0 (1.4)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
(In reply to Francisco Jordano [:arcturus] [:francisco] from comment #2)
> Requesting QAWANTED to check this.

No repro on Flame or Buri devices (We do not have a Peak device)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]

Comment 7

4 months ago
Firefox OS is not being worked on
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.