GTK3 dark theme some text unreadable

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: supaiku, Unassigned)

Tracking

33 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8440402 [details]
Bildschirmfoto vom 2014-06-15 17:49:56.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:33.0) Gecko/20100101 Firefox/33.0 (Beta/Release)
Build ID: 20140612120644

Steps to reproduce:

Run Firefox with Adwaita Dark.



Actual results:

Some websites like reddit are mostly unreadable. I attached a screenshot.


Expected results:

The text should be readable.

Comment 1

4 years ago
In the preferences, under "Content" and "Colors", do you have "Allow pages to choose their own colors, instead of my selections above" unticked?
Flags: needinfo?(asdf.crush)
(Reporter)

Comment 2

4 years ago
Hi Gijs,

that did the trick. I unticked "Use system colors" and now the text color is just as expected. But why is that setting a default? In case of a dark theme it leads to a suboptimal experience.
Flags: needinfo?(asdf.crush)

Comment 3

4 years ago
(In reply to supaiku from comment #2)
> Hi Gijs,
> 
> that did the trick. I unticked "Use system colors" and now the text color is
> just as expected. But why is that setting a default? In case of a dark theme
> it leads to a suboptimal experience.

It isn't:

http://mxr.mozilla.org/mozilla-central/source/modules/libpref/src/init/all.js#149

You (or an add-on) must have changed it at one point or another. If you create a new profile, it should not happen there either.


I'm going to mark this WFM. :-)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME

Comment 4

4 years ago
Created attachment 8519415 [details]
inputs have inherited system colours despite setting being off

Gijs, while that listing says the default is false, it isn't so on my install (firefox-33.0-4.fc22.x86_64).

browser.display.use_system_colors is set to true by default and if I toggle it in about:config it is set to false and the whole row's font gains weight (gets bold).

The problem, of course, is that web sites whose designers didn't specify both default background and foreground colours for their whole document can be broken because they're expecting defaults of black txt and white bg.

It would be great if just flipping browser.display.use_system_colors was enough to fix everything - but it isn't; unstyled input fields have issues irrespective of that setting.

Comment 5

4 years ago
(In reply to Jaša Bartelj from comment #4)
> Created attachment 8519415 [details]
> inputs have inherited system colours despite setting being off
> 
> Gijs, while that listing says the default is false, it isn't so on my
> install (firefox-33.0-4.fc22.x86_64).

That sounds like a fedora build? You should take this up with upstream.

Note also that use_system_colors and use_document_colors are different things. You probably want 'true' for use_document_colors ("Allow pages to choose their own colors, instead of my selections above"), and use_system_colors ("Use system colors" - both are in the same dialog indicated in comment #1!) controls whether the default foreground and background colors are the ones set there (black on white by default) or the system defaults.
You need to log in before you can comment on or make changes to this bug.