Closed Bug 1025698 Opened 6 years ago Closed 6 years ago

alternate search providers are broken in homescreen search bar with multi-word searches

Categories

(Firefox OS Graveyard :: Gaia::Search, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 verified)

VERIFIED DUPLICATE of bug 1026269
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: bkelly, Unassigned)

Details

(Keywords: regression, Whiteboard: [systemsfe])

I tried switching my search provider in Settings->Homescreen->Search Engine.  I tried both google and bing, but neither worked.

Instead of sending my search parameters to the selected search engine, it instead seemed to search on google for the selected search engine itself.

So if I had selected bing and searched for foobar, it searched google for "bing" instead of search bing for "foobar".

This seems completely busted so nom'ing for blocking.
Weird. I thought this was working when I was looked at this initially. Maybe something regressed?
QA Whiteboard: [VH-FL-blocking+][VH-FC-blocking+]
Keywords: regression
Whiteboard: [systemsfe]
Forgot to mention:  v2.0 flame following pvt nightlies
blocking-b2g: 2.0? → 2.0+
Blocks: 1015336
No longer blocks: vertical-homescreen
Currently unable to reproduce this on master and v2.0. Adding qawanted for a screenshot and logcat if possible. Thanks!
Keywords: qawanted
WFM too now.  Must have been fixed as a side effect of something else in the last day or two?  Or I'm crazy?
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
We're landing stuff like crazy, so possibly fixed. Thanks!
Keywords: qawanted
I also wiped my VH IDB database this morning.  Maybe that fixed something??
Actually, I was just able to reproduce.

1) Set search provider to bing in Settings->Homescreen->Search Provider
2) On homescreen search for the pizza/sub shop near my house by typing "santinis oakton".
3) See that it brings up a google search with bing results.

It appears that the multi-word search terms are not contained in quotes, so the URL is malformed and triggers a google search.

Note, I can also not click on google result circles under everything.me for this search term.  Is that the same issue?
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Summary: alternate search providers are broken in homescreen search bar → alternate search providers are broken in homescreen search bar with multi-word searches
Ah, interesting. So if you press 'enter' after typing it brings you to bing? I think what's happening here is that E.me is returning a google search result, which just does a raw search of your term. I don't think it's anything we can really fix while we use EverythingMe, but we may be able to ask them to stop returning a generic google search link? Not being able to tap on globe links is being tracked in bug 1025178.

Doing a ni? on UX as this is pretty good feedback.
Flags: needinfo?(firefoxos-ux-bugzilla)
Note: There is also bug 1026269 in case you are seeing that.
This looks like a dupe of bug 1026269 (or the other way around).

This may have regressed when we switched to using web activites. We're probably passing a URL with spaces in it which the view URL web activity interprets as search terms rather than a URL. So rather than searching the homescreen search provider for search terms using the URL constructed in the search app, it searches the browser's search provider for the constructed search URL with spaces in!

We probably just need to URL encode the string.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1026269
No longer blocks: 1015336
Verified as dup.
Status: RESOLVED → VERIFIED
Gaia      756f1ae83413fe6bf5e8b6f985fb03da1bab02d4
Gecko     https://hg.mozilla.org/mozilla-central/rev/e86b84998b18
BuildID   20140624040203
Version   33.0a1
ro.build.version.incremental=108
ro.build.date=Tue Jun 10 19:40:40 CST 2014
flame

(double check since fix landed)
Flags: needinfo?(firefoxos-ux-bugzilla)
You need to log in before you can comment on or make changes to this bug.