[Flame v1.3] [Wifi] - Unable to turn on Wi-Fi

RESOLVED WORKSFORME

Status

Firefox OS
Wifi
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: rdaub, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8440528 [details]
turning_on_wifi.log

Hi,

I'm not sure how the phone got into this state, this happened twice in the last two days - I try to turn on Wi-Fi but it does not turn on. Restarting the device does not help.


ENVIRONMENT: 
Flame reference device
Version: 1.3.0.0-prerelease
Build ID: 20140610200025

STEPS TO REPRODUCE:
1. Pull down the notification bar and tap on the Wifi icon to turn it on, or go into Settings > Wi-Fi and turn it on.

EXPECTED RESULTS:
Wi-Fi should turn on, and a list of available networks should be displayed. If there are known networks, it should connect to the strongest one.

ACTUAL RESULTS:
The "Wi-Fi switch" in the Settings menu is activated, "Available networks" shows "Searching..." for a few seconds, and then the "Wi-Fi switch" turns off by itself. (see screenshot)


I have taken a logcat of turning on the Wi-Fi, and it being automatically turned off 4 times.

Please let me know if there is any information I could provide to help with the investigation and troubleshooting of this issue.

Thanks,
- Ralph
(Reporter)

Comment 1

4 years ago
Created attachment 8440529 [details]
Turning on Wi-Fi

Wi-Fi automatically turns off after a few seconds of "Searching..." for available networks.
I don't know if this is the same problem or not. We're having the same problem on 2.0. Wifi just doesn't work. It doesn't seem to be a gecko problem since when I update/flash just gecko and gaia over an old build, it works.

Copying a configured wpa_supplicant.conf on /data/misc/wifi and trying to start the service manually (via adb shell start wpa_supplicant) gives the following log:

D/wpa_supplicant( 1565): Could not open file /sys/class/net/wlan0/phy80211/name: No such file or directory

Before updating, /sys/class/net/wlan0 that file is a symbolic link to a directory that doesn't exist after updating.
I don't think this is a Gecko problem, the problem seems to come from upstream/gonk. For some reason the wlan0 device isn't configured correctly. Can you take a look, Michael?
Flags: needinfo?(mvines)
Ni to youlong.jiang to see if he can help.
Flags: needinfo?(youlong.jiang)
Not sure, I don't have access to Flame builds and wifi works fine here on our devices.
Flags: needinfo?(mvines)
With today's build, it seems to be working again.
(Reporter)

Comment 7

4 years ago
To be clear - Wi-Fi was originally working on the build that I was using.

Somehow, after a couple of weeks of using the phone, the phone got into a state where Wi-Fi would no longer turn on. This remained for over a week after restarting and soft-resetting the phone (removing the battery). After I did a factory reset, the Wi-Fi started working again. 

I hope this helps to clarify. Please let me know if there are any questions.

Thanks,
- Ralph

Comment 8

3 years ago
verify with Flame KK base image v162-3, it's fine
I guess we can close this bug as WFM.
Flags: needinfo?(youlong.jiang)
base on comment8, WFM
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.