Crash [@ mozilla::layers::BasicCompositor::BeginFrame] when loading invalid chrome

RESOLVED WONTFIX

Status

()

P3
major
RESOLVED WONTFIX
5 years ago
15 days ago

People

(Reporter: neil, Unassigned)

Tracking

({crash})

23 Branch
crash
Points:
---

Firefox Tracking Flags

(firefox-esr60 affected, firefox64 affected, firefox65 affected)

Details

(Whiteboard: [gfx-noted], crash signature)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 8440571 [details]
Stack backtrace (debug build)

I tried to open an add-on's XUL page directly from the browser console but mistyped it. The window crashed trying to load the "Problem loading page".

I found an easy way to reproduce the problem on my XP system which is
firefox -chrome chrome://global/content/mistyped.xul

I tried this on a Windows 7 system and the window opens at zero width and does not crash (on XP the window covers the desktop, I don't know why there would be a difference).

I tried again with a debug build and these are the last few lines in the console:
[247164] WARNING: Direct3D 11-accelerated layers are not supported on this system.: file gfx/layers/d3d11/CompositorD3D11.cpp, line 110
[247164] WARNING: Direct3D 9-accelerated layers are not supported on this system.: file gfx/layers/d3d9/CompositorD3D9.cpp, line 43
++DOMWINDOW == 6 (0D09A400) [pid = 247164] [serial = 6] [outer = 0C83C400]
??????????p: N[247164] WARNING: Failed to allocate buffer: file gfx\layers\client/TextureClient.cpp, line 505
[247164] WARNING: Failed to allocate buffer: file gfx\layers\client/TextureClient.cpp, line 505
[247164] WARNING: Could not allocate texture client: file gfx\layers\client/ContentClient.cpp, line 210
(Reporter)

Comment 1

5 years ago
> ??????????p: N
This is a bug in _cairo_win32_print_gdi_error, it's trying to print "_create_dc_and_bitmap: Not enough storage is available to process this command." but it's incorrectly matching fwprintf with fprintf's format specifiers. The bug was fixed in bug 624198 but it was regressed by bug 562746.
(Reporter)

Comment 2

5 years ago
> > ??????????p: N
> This is a bug in _cairo_win32_print_gdi_error, it's trying to print
> "_create_dc_and_bitmap: Not enough storage is available to process this
> command." but it's incorrectly matching fwprintf with fprintf's format
> specifiers. The bug was fixed in bug 624198 but it was regressed by bug
> 562746.
This is covered by bug 710976.
(Reporter)

Comment 3

5 years ago
> on XP the window covers the desktop, I don't know why
This explains the error creating the bitmap - the window's size is 32759×32733.
(Reporter)

Comment 4

5 years ago
If I try this in Gecko 4 (didn't have anything else handy) then I get a really small window, so I guess there must be some sort of widget regression that is tickling this bug.

Updated

3 years ago
Crash Signature: [@ mozilla::layers::BasicCompositor::BeginFrame(nsIntRegion const&, mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits> const*, mozilla::gfx::Matrix const&, mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits> const&, mozilla::gfx::RectTyped<mozilla::gfx::… → [@ mozilla::layers::BasicCompositor::BeginFrame(nsIntRegion const&, mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits> const*, mozilla::gfx::Matrix const&, mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits> const&, mozilla::gfx::RectTyped<mozilla::gfx::…
There are crashes on all platforms but it's really low volume:
* Firefox 50.0 Beta has 1 report so far
* Firefox 49.0.1 has 1 report so far
* Firefox 48.0.2 had 7 reports
* No crashes yet for Firefox 51.0a2 or 52.0a1
OS: Windows XP → All
Hardware: x86 → All
Whiteboard: [gfx-noted]
Version: unspecified → 23 Branch
Closing because no crashes reported for 12 weeks.
Status: NEW → RESOLVED
Last Resolved: 15 days ago
Resolution: --- → WONTFIX
Closing because no crashes reported for 12 weeks.
There are still some crashes so reopen it.
status-firefox64: --- → affected
status-firefox65: --- → affected
status-firefox-esr60: --- → affected
You need to log in before you can comment on or make changes to this bug.