Closed Bug 1025847 Opened 8 years ago Closed 8 years ago

Quit Firefox with shortcut when pressing Ctrl+A while using AZERTY and(?) Arabic

Categories

(Firefox :: Untriaged, defect)

26 Branch
x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 550559

People

(Reporter: btabdllatif2, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131206152524

Steps to reproduce:

- set language to Arabic
- try to select the full text over web page using Ctrl+A.



Actual results:

Firefox quit without notice


Expected results:

select full content of the web page
The browser should at least warn the user before closing.
Since I am using AZERTY it shouldn't switch to QWERTY when using Arabic.
(In reply to btabdllatif2 from comment #1)
> The browser should at least warn the user before closing.

There are preferences to configure whether the browser warns before closing.

> Since I am using AZERTY it shouldn't switch to QWERTY when using Arabic.

Are you sure it was the browser that switched, not your OS? AFAIK Firefox itself doesn't mess with your OS's keyboard layouts, but I would fully expect Ubuntu to have associated keyboard layouts with languages...

Also, is your Firefox in English or in some other language?
Flags: needinfo?(btabdllatif2)
Summary: Quit Firefox with shortcut while using Arabic → Quit Firefox with shortcut when pressing Ctrl+A while using AZERTY and(?) Arabic
when I choose to notice me before quit ... it doesn't work and the navigator Quit without notice !!
Flags: needinfo?(btabdllatif2)
(In reply to btabdllatif2 from comment #3)
> Created attachment 8442011 [details]
> when I choose to notice me before quit ... it doesn't work and the navigator
> Quit without notice !!
> 
> when I choose to notice me before quit ... it doesn't work and the navigator
> Quit without notice !!

This is expected if your "When Firefox Starts" preference says "show my windows and tabs from last time".


In any case, you've not answered my question...

(In reply to :Gijs Kruitbosch from comment #2)
> (In reply to btabdllatif2 from comment #1)
> > Since I am using AZERTY it shouldn't switch to QWERTY when using Arabic.
> 
> Are you sure it was the browser that switched, not your OS? AFAIK Firefox
> itself doesn't mess with your OS's keyboard layouts, but I would fully
> expect Ubuntu to have associated keyboard layouts with languages...
Flags: needinfo?(btabdllatif2)
So About switching to QWERTY I think is my OS who do that ... 
the problem resolved with more than two tabs but if I have one it still Quit without notice ...
Flags: needinfo?(btabdllatif2)
Yes, that issue is tracked in either bug 502908 or bug 550559, depending on how exactly you feel about this. I'm picking bug 550559 to dupe to in this case.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 550559
thank you so much Mr. Gijs Kruitbosh :)
You need to log in before you can comment on or make changes to this bug.