Closed Bug 1025896 Opened 8 years ago Closed 8 years ago

crash in mozilla::gfx::DrawTargetD2D::MaskSurface(mozilla::gfx::Pattern const&, mozilla::gfx::SourceSurface*, mozilla::gfx::PointTyped<mozilla::gfx::UnknownUnits>, mozilla::gfx::DrawOptions const&)

Categories

(Core :: Graphics: Layers, defect)

33 Branch
x86
Windows NT
defect
Not set
critical

Tracking

()

VERIFIED FIXED
mozilla33
Tracking Status
firefox33 - verified

People

(Reporter: tracy, Assigned: mattwoodrow)

Details

(Keywords: crash, regression, topcrash-win)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-eddf9c43-1270-411d-86e2-4548e2140613.
=============================================================

This crash began appearing in Nightly with builds from 2014061203.  It is currently #5 in volume on the topcrash list.  It is only present on Win 7, 8 and 8.1.  

Tow reporter comments:

"Logging into Star Trek Online."

"crashed when updating graphic driver" 

URL's for this crash indicate general browser usage. Nothing useful.
regression range: 20140611030204 - 20140612030349
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=18c21532848a&tochange=9e8e3e903484

Bas, possible suspect Bug 992491 - Add a tiled DrawTarget
Flags: needinfo?(bas)
No, this will be bug 940845.
Flags: needinfo?(bas) → needinfo?(matt.woodrow)
Looks like we used to do this (and still do at the other callsite).
Assignee: nobody → matt.woodrow
Attachment #8441791 - Flags: review?(bas)
Flags: needinfo?(matt.woodrow)
Attachment #8441791 - Flags: review?(bas) → review+
I can reproduce this crash by resetting my graphics driver while running Firefox (using `devcon restart <deviceID>`).
https://hg.mozilla.org/mozilla-central/rev/c69b9ec44533
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla33
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.