Open Bug 1025931 Opened 6 years ago Updated Last year

Crash java.lang.NullPointerException in in org.mozilla.gecko.GeckoAppShell.getContext

Categories

(Firefox for Android :: General, defect, P5, critical)

31 Branch
ARM
Android
defect

Tracking

()

REOPENED
Tracking Status
firefox31 - fixed
firefox32 - fixed
firefox33 --- affected
fennec + ---

People

(Reporter: aaronmt, Unassigned)

References

(Depends on 1 open bug)

Details

(Keywords: crash)

Attachments

(1 file)

java.lang.RuntimeException: Unable to resume activity {org.mozilla.firefox_beta/org.mozilla.gecko.preferences.GeckoPreferences}: java.lang.NullPointerException
at android.app.ActivityThread.performResumeActivity(ActivityThread.java:2924)
at android.app.ActivityThread.handleResumeActivity(ActivityThread.java:2953)
at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2405)
at android.app.ActivityThread.access$600(ActivityThread.java:153)
at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1269)
at android.os.Handler.dispatchMessage(Handler.java:99)
at android.os.Looper.loop(Looper.java:137)
at android.app.ActivityThread.main(ActivityThread.java:5293)
at java.lang.reflect.Method.invokeNative(Native Method)
at java.lang.reflect.Method.invoke(Method.java:525)
at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:738)
at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:554)
at dalvik.system.NativeStart.main(Native Method)
Caused by: java.lang.NullPointerException
at org.mozilla.gecko.GeckoAppShell.getContext(GeckoAppShell.java:2071)
at org.mozilla.gecko.GeckoNetworkManager.getApplicationContext(GeckoNetworkManager.java:63)
at org.mozilla.gecko.GeckoNetworkManager.getConnectionType(GeckoNetworkManager.java:186)
at org.mozilla.gecko.GeckoNetworkManager.start$faab20d(GeckoNetworkManager.java:90)
at org.mozilla.gecko.GeckoApplication.onActivityResume$642b2292(GeckoApplication.java:113)
at org.mozilla.gecko.preferences.GeckoPreferences.onResume(GeckoPreferences.java:246)
at android.app.Instrumentation.callActivityOnResume(Instrumentation.java:1192)
at android.app.Activity.performResume(Activity.java:5350)
at android.app.ActivityThread.performResumeActivity(ActivityThread.java:2914)
... 12 more

There are a large number of crashes on the Android Dashboard with this signature.

Devices:

 * GT-I8190 (4.4.3)
 * Galaxy W (GT-I8150) (2.3)
 * RAZR D1 (hawk35_umts) (4.4.1)
 * Galaxy S3 (m0) (4.3)
 * Nexus 7 (grouper) (4.4)
 * Galaxy Tab3 8.0 (lt01wifi) (4.2)
Severity: normal → critical
tracking-fennec: --- → ?
Assignee: nobody → blassey.bugs
tracking-fennec: ? → 31+
Attachment #8446525 - Flags: review?(snorp) → review+
This is a dupe of Bug 1020412.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1020412
No a dupe
Resolution: DUPLICATE → FIXED
Comment on attachment 8446525 [details] [diff] [review]
NPE_getContext.patch

Approval Request Comment
[Feature/regressing bug #]:
[User impact if declined]:
[Describe test coverage new/current, TBPL]:
[Risks and why]: 
[String/UUID change made/needed]:

Top crash in the android play store reporting (before our crash reporting gets hooked up)
Attachment #8446525 - Flags: approval-mozilla-beta?
Attachment #8446525 - Flags: approval-mozilla-aurora?
Brad, could you fill the uplift request form? we need it before approving any patch. Thanks
Flags: needinfo?(blassey.bugs)
(In reply to Sylvestre Ledru [:sylvestre] from comment #7)
> Brad, could you fill the uplift request form? we need it before approving
> any patch. Thanks

The form is a guide, not a requirement. This patch is setting our context getter on a code path we missed to fix a top crash. I can approve it myself if you'd rather.
Flags: needinfo?(blassey.bugs)
Comment on attachment 8446525 [details] [diff] [review]
NPE_getContext.patch

While it is generally beneficial to provide the information requested in a standard format, in this bug we do have all the information that we need to proceed. Approved for Beta and Aurora.
Attachment #8446525 - Flags: approval-mozilla-beta?
Attachment #8446525 - Flags: approval-mozilla-beta+
Attachment #8446525 - Flags: approval-mozilla-aurora?
Attachment #8446525 - Flags: approval-mozilla-aurora+
Depends on: 1034017
Attachment #8446525 - Flags: approval-mozilla-beta+
Attachment #8446525 - Flags: approval-mozilla-aurora+
Depends on: 1034135
I may have missed something. What happened to result in a backout?
Flags: needinfo?(blassey.bugs)
(In reply to Lawrence Mandel [:lmandel] from comment #13)
> I may have missed something. What happened to result in a backout?

Bug 1034017. (See dependencies.)

Bug 1034017 Comment 5 explains the failure.

Bug 1034135 tracks the correct solution.
Flags: needinfo?(blassey.bugs)
bug 1020412 mitigated this crash for beta. Recommending untracking this bug.
OK. Thanks for the information.
tracking-fennec: ? → +
filter on [mass-p5]
Priority: -- → P5
Assignee: lassey → nobody
You need to log in before you can comment on or make changes to this bug.