Crash java.lang.NullPointerException at org.mozilla.gecko.background.healthreport.HealthReportBroadcastService.onHandleIntent(HealthReportBroadcastService.java:104)

RESOLVED FIXED in Firefox 31

Status

()

Firefox for Android
General
--
critical
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: aaronmt, Assigned: rnewman)

Tracking

({crash})

31 Branch
Firefox 33
ARM
Android
crash
Points:
---

Firefox Tracking Flags

(firefox31+ fixed, firefox32 fixed, firefox33 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
java.lang.NullPointerException
at org.mozilla.gecko.background.healthreport.HealthReportBroadcastService.onHandleIntent(HealthReportBroadcastService.java:104)
at android.app.IntentService$ServiceHandler.handleMessage(IntentService.java:65)
at android.os.Handler.dispatchMessage(Handler.java:99)
at android.os.Looper.loop(Looper.java:137)
at android.os.HandlerThread.run(HandlerThread.java:61)

There is still a large volume of crash reports on the Android Google Play Dashboard with this signature.

User messages seem to indicate that this happens on startup.
(Assignee)

Comment 1

4 years ago
You say "still" - what's the history here?
(Reporter)

Comment 2

4 years ago
nm, was thinking of the org.mozilla.gecko.background.healthreport.prune.HealthReportPruneService ANR which is still high volume
(Assignee)

Comment 3

4 years ago
See also Bug 903136.
(Assignee)

Comment 4

4 years ago
It looks like this occurs if the intent is null. Which is unexpected in an IntentService, and yet people see it for other services. Misc research findings:

https://code.google.com/p/gcm/issues/detail?id=20
http://pastebin.com/gfY4EjD7
http://stackoverflow.com/questions/15808793/how-could-intent-be-null-in-onhandleintent
http://stackoverflow.com/questions/8421430/reasons-that-the-passed-intent-would-be-null-in-onstartcommand?rq=1
(Assignee)

Updated

4 years ago
Assignee: nobody → rnewman
Status: NEW → ASSIGNED
(Assignee)

Comment 5

4 years ago
Created attachment 8440842 [details] [review]
Proposed patch. v1
Attachment #8440842 - Flags: review?(michael.l.comella)
Comment on attachment 8440842 [details] [review]
Proposed patch. v1

r+ w/ nits.
Attachment #8440842 - Flags: review?(michael.l.comella) → review+
(Assignee)

Comment 7

4 years ago
https://hg.mozilla.org/integration/fx-team/rev/e1c288cf638a
status-firefox32: --- → affected
status-firefox33: --- → affected
(Assignee)

Comment 8

4 years ago
This warrants uplift after bake.
Flags: needinfo?(rnewman)
https://hg.mozilla.org/mozilla-central/rev/e1c288cf638a
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 33
(Reporter)

Updated

4 years ago
tracking-firefox31: --- → ?
(Assignee)

Comment 10

4 years ago
Comment on attachment 8440842 [details] [review]
Proposed patch. v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
  Old work for HealthReport service, but generally all services.

User impact if declined: 
  Occasional crashes.

Testing completed (on m-c, etc.): 
  Only positive testing: doesn't regress normal behavior. This patch addresses edge case crashes.

Risk to taking this patch (and alternatives if risky): 
  Null checks, so should be ~none.

String or IDL/UUID changes made by this patch:
  None.
Attachment #8440842 - Flags: approval-mozilla-aurora?
Flags: needinfo?(rnewman)
(Assignee)

Updated

4 years ago
Attachment #8440842 - Flags: approval-mozilla-beta?
status-firefox33: affected → fixed
Attachment #8440842 - Flags: approval-mozilla-beta?
Attachment #8440842 - Flags: approval-mozilla-beta+
Attachment #8440842 - Flags: approval-mozilla-aurora?
Attachment #8440842 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/48a5056b5d98
https://hg.mozilla.org/releases/mozilla-beta/rev/ae79355021e5
status-firefox31: affected → fixed
status-firefox32: affected → fixed
tracking-firefox31: ? → +
(Reporter)

Updated

4 years ago
Duplicate of this bug: 1030740
(Assignee)

Updated

4 years ago
Depends on: 1030740
You need to log in before you can comment on or make changes to this bug.