Closed Bug 1025956 Opened 8 years ago Closed 8 years ago

Categories

(Firefox :: Theme, defect)

x86
Windows 8
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 33
Tracking Status
firefox32 --- verified
firefox33 --- verified

People

(Reporter: florian, Assigned: florian)

References

Details

(Whiteboard: [translation] p=1 s=33.1 [qa!])

Attachments

(1 file)

I don't have a Windows machine with hidpi to test, but from my understanding of the IRC conversation I just had with Gijs (http://logs.glob.uno/?c=mozilla%23fx-team#c148026), this causes the translation infobar's dropdown arrow to be invisible, so it sounds like something we should fix on aurora for our pre-trial of the translation feature.
I suspect I added a 2x rule when I was using the in-content style for the dropdown (that has a 2x image), then the design changed 3 or 4 times in a row and the rule became a leftover.

Yes, we should either add the 2x image or remove the rule.
Attached patch Remove the rule.Splinter Review
(In reply to Marco Bonardo [:mak] from comment #1)

> Yes, we should either add the 2x image or remove the rule.

Thanks, let's remove the rule for now.
Assignee: nobody → florian
Status: NEW → ASSIGNED
Attachment #8440741 - Flags: review?(gijskruitbosch+bugs)
Comment on attachment 8440741 [details] [diff] [review]
Remove the rule.

Review of attachment 8440741 [details] [diff] [review]:
-----------------------------------------------------------------

r=me
Attachment #8440741 - Flags: review?(gijskruitbosch+bugs) → review+
https://hg.mozilla.org/integration/fx-team/rev/8e2eee346e62

Marco, I just handled this trivial fix immediately; you may want to add it to the current iteration or ignore it.
Flags: needinfo?(mmucci)
Flags: firefox-backlog+
QA Contact: bogdan.maris
Whiteboard: [translation] p=1 [qa+]
Added to Iteration 33.1
Flags: needinfo?(mmucci)
Whiteboard: [translation] p=1 [qa+] → [translation] p=1 s=33.1 [qa+]
Comment on attachment 8440741 [details] [diff] [review]
Remove the rule.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): This bug is part of the automatic translation feature, which we want to A/B with a subset of Aurora 32 users.
User impact if declined: the dropdown would have no arrow icon on Windows on hidpi.
Testing completed (on m-c, etc.): will be verified on m-c by QA
Risk to taking this patch (and alternatives if risky): none
String or IDL/UUID changes made by this patch: none
Attachment #8440741 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/8e2eee346e62
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 33
Comment on attachment 8440741 [details] [diff] [review]
Remove the rule.

Aurora approval granted.
Attachment #8440741 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified that the dropdown arrows appear now on all infobar buttons on Windows 8.1 64bit Surface Pro 2 using latest Nightly. Please flip back the [qa+] keyword once the fix arrives in Aurora.
Status: RESOLVED → VERIFIED
Whiteboard: [translation] p=1 s=33.1 [qa+] → [translation] p=1 s=33.1 [qa!]
https://hg.mozilla.org/releases/mozilla-aurora/rev/883d156210cf
Whiteboard: [translation] p=1 s=33.1 [qa!] → [translation] p=1 s=33.1 [qa+]
Verified fixed on Aurora 32 (2014-06-19) as well, using a Microsoft Surface Pro 2 with Windows 8.1 64-bit.
Whiteboard: [translation] p=1 s=33.1 [qa+] → [translation] p=1 s=33.1 [qa!]
You need to log in before you can comment on or make changes to this bug.