Closed Bug 1026081 Opened 6 years ago Closed 6 years ago

[B2G][Dialer]Dial pad does not function while in a call with bug 981519 landed

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.0+, b2g-v1.3 unaffected, b2g-v1.4 unaffected, b2g-v2.0 verified, b2g-v2.1 verified)

VERIFIED FIXED
2.0 S4 (20june)
blocking-b2g 2.0+
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.4 --- unaffected
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: astole, Assigned: drs)

References

()

Details

Attachments

(3 files, 2 obsolete files)

Attached file logcat
While in a call, pressing any number or symbol on the dial pad does affect the call, the number or symbol lights up when pressed but nothing happens. This happens whether a call is inbound or outbound.

Repro Steps:
1) Update a Flame to BuildID: 20140616040202
2) Make a call
3) While in the call, open the dial pad and tap any number

Actual:
Dial pad does not function

Expected:
Pressing a number or symbol on the dial pad affects the call appropriately

2.1 Environmental Variables:
Device: Flame 2.1 MOZ
BuildID: 20140616040202
Gaia: dfc4703bb81d1fa4f2087a1a6124b47a80a5d1de
Gecko: 80431d4fd0da
Version: 33.0a1
Firmware Version: v121-2

Repro frequency: 2/2, 100%
See attached: logcat, video
This issue does not occur on the latest 2.0

Device: Flame 2.0 MOZ
BuildID: 20140616000203
Gaia: a6988c15b361938bea5976c846c147ecdc1121c0
Gecko: 52a276202888
Version: 32.a1
Firmware Version: v121-2

qawanted to test other branches and devices.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qaurgent
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: croesch
2.1 User Agent: 
Mozilla/5.0 (Mobile;rv:33.0) Gecko/33.0 Firefox/33.0

2.0 User Agent: 
Mozilla/5.0 (Mobile;rv:32.0) Gecko/32.0 Firefox/32.0
Attaching video
This bug does NOT repro on Flame 1.4. The numbers pressed appear in the display and audio is heard.

Environmental Variables:
Device: Flame 1.4
Build ID: 20140616000202
Gaia: 164644d91290708a71436dfdf4301e33b92e2c77
Gecko: 2949e8bef869
Version: 30.0 (1.4) 
Firmware Version: v121-2

----------------------------------------------------

This bug does NOT repro on Buri 2.0. The numbers pressed appear in the display and audio is heard.

Environmental Variables:
Device: Buri 2.0
Build ID: 20140616103417
Gaia: 5da2b8a8c844af85b6825caa102f8cbe8b30b648
Gecko: 76bc5db75c1f
Version: 32.0a2 (2.0) 
Firmware Version: v1.2device.cfg

------------------------------------------------

This bug does NOT repro on OpenC 2.0. The numbers pressed appear in the display and audio is heard.


Environmental Variables:
Device: Open_C 2.0
Build ID: 20140616000203
Gaia: a6988c15b361938bea5976c846c147ecdc1121c0
Gecko: 52a276202888
Version: 32.0a2 (2.0) 
Firmware Version: P821A10V1.0.0B06_LOG_DL

-------------------------------------------------

This bug does NOT repro on flame Base v121-2. The numbers pressed appear in the display and audio is heard.

Environmental Variables:
Device: Flame 1.3
Build ID: 20140610200025
Gaia: e106a3f4a14eb8d4e10348efac7ae6dea2c24657
Gecko: b637b0677e15318dcce703f0358b397e09b018af
Version: 28.0 (1.3) 
Firmware Version: v121-2
Flags: needinfo?(jmitchell)
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: croesch → jmercado
blocking-b2g: --- → 2.1?
B2g-inbound Regression Window

Last working 
Environmental Variables:
Device: Flame
BuildID: 20140612001231
Gaia: ba365c8f7feda34e582ce1721cf538f417c92a75
Gecko: d958dbb63fca
Version: 33.0a1

First Broken 
Environmental Variables:
Device: Flame
BuildID: 20140612002012
Gaia: ba365c8f7feda34e582ce1721cf538f417c92a75
Gecko: db71d2354a77
Version: 33.0a1

Last working gaia / First broken gecko - Issue DOES occur
Gaia: ba365c8f7feda34e582ce1721cf538f417c92a75
Gecko: db71d2354a77

First broken gaia / Last working gecko - Issue does NOT occur
Gaia: ba365c8f7feda34e582ce1721cf538f417c92a75
Gecko: d958dbb63fca

Gecko Pushlog:  http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=d958dbb63fca&tochange=db71d2354a77
Flags: needinfo?(jmitchell)
Broken by bug 981519. Will ask Hsin-Yi for backout on that bug.
Blocks: 981519
Component: Gaia::Dialer → RIL
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Component: RIL → Gaia::Dialer
Seems we missed shared/js/dialer/keypad.js in Bug 1005766.
This test patch fixes this issue.

Gabriele or Doug,
Could any of you help me finish the patch and related tests? Thank you.
Flags: needinfo?(gsvelto)
Flags: needinfo?(drs+bugzilla)
Regressing patch was backed out, so I'm clearing the keywords & reworking the title to indicate that this needs bug 981519 to land to trigger this bug.
Summary: [B2G][Dialer]Dial pad does not function while in a call → [B2G][Dialer]Dial pad does not function while in a call with bug 981519 landed
blocking-b2g: 2.1? → ---
The issue still occurs in today's build (fails one of the manual smoke tests), will retest tomorrow

Flame 2.1
BuildID: 20140617040203
Gaia: eac13407742a55b11e1877b4df2abdfd22cd582e
Gecko: bb35d1b73634
Version: 33.0a1
V121-2
Keywords: smoketest
(In reply to Natalya Kot [:nkot] from comment #9)
> The issue still occurs in today's build (fails one of the manual smoke
> tests), will retest tomorrow
> 
> Flame 2.1
> BuildID: 20140617040203
> Gaia: eac13407742a55b11e1877b4df2abdfd22cd582e
> Gecko: bb35d1b73634
> Version: 33.0a1
> V121-2

This already fixed by backout, so we don't need the keyword here.
Keywords: smoketest
Gabriele, I think we also missed call_log_db_test.js, though this spot is less important since the data is mocked. Can you fix this and I'll review it? (I can't ask you for review if I fix it.)
Nevermind, I think Gabriele is on mat leave, so I'll take this.
Assignee: nobody → drs+bugzilla
Status: NEW → ASSIGNED
Flags: needinfo?(gsvelto)
Flags: needinfo?(drs+bugzilla)
That was the only spot that I can see that we needed to fix. I included an extra test.
Attachment #8441189 - Attachment is obsolete: true
Attachment #8441649 - Flags: review?(etienne)
Rebased.

PR: https://github.com/mozilla-b2g/gaia/pull/20634
Attachment #8441649 - Attachment is obsolete: true
Attachment #8441649 - Flags: review?(etienne)
Attachment #8441686 - Flags: review?(etienne)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
Duplicate of this bug: 1026940
Comment on attachment 8441686 [details] [diff] [review]
Fix missed telephony API upgrade to TelephonyCallId.

Review of attachment 8441686 [details] [diff] [review]:
-----------------------------------------------------------------

r=me with the small comment on github addressed.
Sorry for the backout Hsin-Yi :/
Attachment #8441686 - Flags: review?(etienne) → review+
(In reply to Etienne Segonzac (:etienne) from comment #16)
> Comment on attachment 8441686 [details] [diff] [review]
> Fix missed telephony API upgrade to TelephonyCallId.
> 
> Review of attachment 8441686 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> r=me with the small comment on github addressed.
> Sorry for the backout Hsin-Yi :/

Never mind. And thanks for helping this out :D
Fixed code review comment.

https://github.com/mozilla-b2g/gaia/commit/28f2e2ee44d869b0de3ea860ca26955448398811
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
2.0 is now affected by this because bug 981519 got uplifted. I will go ahead and uplift it before triage comes in because it is causing bug 1039844, a smoketest failure.
blocking-b2g: --- → 2.0?
Target Milestone: --- → 2.0 S4 (20june)
(In reply to Anthony Ricaud (:rik) from comment #19)
> 2.0 is now affected by this because bug 981519 got uplifted. I will go ahead
> and uplift it before triage comes in because it is causing bug 1039844, a
> smoketest failure.

Makes sense. Blocking on that basis.
blocking-b2g: 2.0? → 2.0+
Status: RESOLVED → VERIFIED
Attached video VIDEO0152.mp4
This issue has been successfully verified on Flame 2.0:
Gaia-Rev        856863962362030174bae4e03d59c3ebbc182473
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/e40fe21e37f1
Build-ID        20141207000206
Version         32.0
Device-Name     flame
FW-Release      4.4.2

This issue has been successfully verified on Flame 2.1:
Gaia-Rev        38e17b0219cbc50a4ad6f51101898f89e513a552
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/8b92c4b8f59a
Build-ID        20141205001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
You need to log in before you can comment on or make changes to this bug.