deleted attachment hangs Mozilla

VERIFIED WORKSFORME

Status

MailNews Core
Movemail
--
blocker
VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: Aaron Stromas, Assigned: Adam D. Moss)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Here is the scenario. I was too lazy to compose a message anew so I edited the
old sent message which had an attachment. The file that was orifinally attached
was called ams-cv.doc but in attachment panel it appeared as ams-cv-2.doc (I
edited this message a couple of times before). Concerned that I didn't have
/tmp/ams-cv-2.doc anymore, I removed the attachment and re-attached it from the
directory it lives in, ~/windoz/ams.doc, and sent the mail. When mozilla hang I
used strace -p to see what was going on and saw this line scrolling
repeatedly:at("/tmp/ams-cv-2.doc", 0xbfffebc4)  = -1 ENOENT (No such file or
directory)

I symlinked /tmp/ams-cv-2.doc to ~/windoz/ams-cv.doc and Mozilla unstuck. A bug,
methinks. Why aren't the attachments left behind in /tmp, anyway?
Cheers

Comment 1

17 years ago
Marking these all WORKSFORME sorry about lack of response but were very
overloaded here. Only reopen the bug if you can reproduce with the following steps:

1) Download the latest nightly (or 0.9.6 which should be out RSN)
2) Create a new profile
3) test the bug again

If it still occurs go ahead and reopen the bug. Again sorry about no response
were quite overloaded here and understaffed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Updated

17 years ago
QA Contact: esther → trix

Comment 2

17 years ago
works for me on the 0.9.6 build of mozilla
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.