Error : Attempt to use .WrappedJSObject in untrusted code

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: Nivesh Naramsetti, Unassigned)

Tracking

29 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

199.21 KB, application/vnd.mozilla.xul+xml
Details
(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140506152807

Steps to reproduce:

My add-on was built using XPCOM and Javascript.It was working totally fine till Firefox28.Just can't figure out the prob with Firefox29.


Actual results:

It was working fine till firefox28.It stopped working since Firefox29.On debugging I found the error message saying 'ERROR: Attempt to use .WrappedJSObject in untrusted code'. So my webpage is not responding at all.Is there any fix to the issue? Help me out.What am I supposed to do? I haven't found any documentation related to this.


Expected results:

The webpage is supposed to respond to the events(Clicks) normally.
(Reporter)

Updated

4 years ago
Summary: WrappedJSObject considered Untrusted in firefox29 → Error : Attempt to use .WrappedJSObject in untrusted code

Comment 1

4 years ago
Can you provide the source code for your add-on?
Flags: needinfo?(nivesh.naramsetti)
(Reporter)

Comment 2

4 years ago
Created attachment 8441378 [details]
ams.tar.gz

This is the source code.But i don't think you can make use of it.Because the add-on links firefox to another internal application in the company which you can't access.See if you can help me out though.Any insights about the issue will be extremely helpful.
Flags: needinfo?(nivesh.naramsetti)

Comment 3

4 years ago
(In reply to Nivesh Naramsetti from comment #2)
> Created attachment 8441378 [details]
> ams.tar.gz
> 
> This is the source code.But i don't think you can make use of it.Because the
> add-on links firefox to another internal application in the company which
> you can't access.See if you can help me out though.Any insights about the
> issue will be extremely helpful.

Which file does the error come from? There are several that use wrappedJSObject...

Have you tried debugging it with the browser toolbox? (open the developer tools, go to settings, enable chrome/add-on debugging, and you get an item in the Tools > Developer Tools menu which lets you debug chrome JS, including add-on JS)
Flags: needinfo?(nivesh.naramsetti)

Comment 4

4 years ago
Also, if this interfaces with an internal web app, that sounds like it might also be that web app using wrappedJSObject and causing an error, especially as it says "untrusted code" in the error message...

Comment 5

4 years ago
I'm closing this as you seem to be getting better help at http://stackoverflow.com/questions/23835434/firefox-29-xpcom-and-wrappedjsobject/23838442#23838442 already.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(nivesh.naramsetti)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.