[Rocketbar] URL is being passed to Google, not search terms

VERIFIED FIXED in Firefox OS v2.0

Status

Firefox OS
Gaia::Search
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: djabber, Assigned: daleharvey)

Tracking

unspecified
2.0 S5 (4july)
x86
Mac OS X

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 verified)

Details

(Whiteboard: [systemsfe])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8441029 [details]
URL is shown in Google search field

If Google is set as the default search provider, and the user enters in search terms that are separated by a space, the Google results show a URL in the Google search box and not the search terms that the user entered. 

Steps to reproduce from Home:
Pre-conditions: Google set as default search provider
1) Tap search field
2) Enter in two or more search terms separated by a space
3) tap Enter

Expected results:
Search terms are shown in the search field in the Google results page

Actual results: 
A URL is shown in the search field
(Reporter)

Updated

4 years ago
blocking-b2g: --- → 2.0?
(Reporter)

Comment 1

4 years ago
Set to blocking as this doesn't complete the search that the user was intending

Updated

4 years ago
Blocks: 1015336
Whiteboard: [systemsfe]
Ben, Dale, can you take a look here?
blocking-b2g: 2.0? → 2.0+
Flags: needinfo?(dale)
Flags: needinfo?(bfrancis)
(Assignee)

Comment 3

4 years ago
Yeh will take this
Assignee: nobody → dale
Flags: needinfo?(dale)
Duplicate of this bug: 1025698
Probably just need to URL encode the constructed search URL before passing it via the web activity (see https://bugzilla.mozilla.org/show_bug.cgi?id=1025698#c9)
Flags: needinfo?(bfrancis)

Updated

4 years ago
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking+]
(Assignee)

Comment 6

4 years ago
Created attachment 8442303 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/20705

Yeh just needed encoding

This feature as a whole really needs integration tests, but didnt want to block this bug on it, but will follow up in another bug with some more testing
Attachment #8442303 - Flags: review?(bfrancis)
(Assignee)

Comment 7

4 years ago
Comment on attachment 8442303 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/20705

Clearing review until I implement tests
Attachment #8442303 - Flags: review?(bfrancis)
(Assignee)

Comment 8

4 years ago
Comment on attachment 8442303 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/20705

Tests added, switch r? to kevin because timezones
Attachment #8442303 - Flags: review?(kgrandon)
Comment on attachment 8442303 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/20705

Darn timezones. This looks good, R+ assuming travis or gaia-try is green.
Attachment #8442303 - Flags: review?(kgrandon) → review+

Updated

4 years ago
Duplicate of this bug: 1027330
status-b2g-v2.0: --- → affected
Summary: URL is being passed to Google, not search terms → [Rocketbar] URL is being passed to Google, not search terms
(Assignee)

Comment 11

4 years ago
https://github.com/mozilla-b2g/gaia/commit/7e0ee26ab10fe5d831d58a0398733676bd6d2381
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
https://hg.mozilla.org/mozilla-central/rev/64e4c08aaf7c
2.0: https://github.com/mozilla-b2g/gaia/commit/34613df564b7899b1d6b8027c7abf860d70a8466
status-b2g-v2.0: affected → fixed
status-b2g-v2.1: --- → fixed
Gaia      9d2f7bd16a8dc0c74c97c5a40d2f0731f3dfff4b
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/f118b45daada
BuildID   20140624000201
Version   32.0a2
ro.build.version.incremental=108
ro.build.date=Tue Jun 10 19:40:40 CST 2014
flame 

Gaia      45479c07cb6ba8c733093d6ee32c767c090c9a28
Gecko     https://hg.mozilla.org/mozilla-central/rev/e86b84998b18
BuildID   20140624040203
Version   33.0a1
ro.build.version.incremental=108
ro.build.date=Tue Jun 10 19:40:40 CST 2014
flame

Verified that it works on 2.0, ran into bug 1029567 on 2.1; flashed my own gaia on top for 2.1 confirmation after backout:
gaia commit 756f1ae83413fe6bf5e8b6f985fb03da1bab02d4
Status: RESOLVED → VERIFIED
status-b2g-v2.0: fixed → verified
status-b2g-v2.1: fixed → verified
Target Milestone: --- → 2.0 S5 (4july)
You need to log in before you can comment on or make changes to this bug.