Closed Bug 1026313 Opened 6 years ago Closed 6 years ago

[Vertical Homescreen] Icon gets stuck when dragging it near the home button

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 verified)

VERIFIED FIXED
2.0 S4 (20june)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: jlorenzo, Assigned: crdlc)

References

Details

(Whiteboard: [systemsfe])

Attachments

(3 files)

Steps to reproduce
1. Enter edit mode
2. Move an icon to the bottom of the screen, as if if you wanted to create a new divider.
3. Let the screen go down.
4. Drag slowly to the homescreen button

Actual result
Icon keeps being big and get stuck. See attached video for details.

Reproducibility rate: 3/10
This issue can be hit by a user who wants to create a new divider and may hurt the first time experience with dividers. Marking the bug as 2.0? blocker.
blocking-b2g: --- → 2.0?
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking+]
blocking-b2g: 2.0? → 2.0+
I cannot reproduce it, could you attach the video commented in the description, thanks a lot
QA Wanted for video.
Keywords: qawanted
I thought a video was attached when I created the bug but it was 1 MB too large actually.
Hi Johan, are you using a Flame device? I am using a hamachi device and I cannot reproduce it, kevin please could you see it?

(In reply to Johan Lorenzo [:jlorenzo] from comment #4)
> Created attachment 8441403 [details]
> Stuck icon - STR - Video
> 
> I thought a video was attached when I created the bug but it was 1 MB too
> large actually.
Flags: needinfo?(kgrandon)
I am not pretty sure but it seems that fails when you move your finger over home button because after releasing your finger the device exists from edit mode. I cannot reproduce it in hamachi or unagi. I try to fix it with this analysis :) I hope I will be right
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
I hope to be right because I am programming without a flame :)
Flags: needinfo?(kgrandon)
Attached file Github pull request
Attachment #8442022 - Flags: review?(kgrandon)
I am scared that we are going to cover-up a real bug that exists with this, and still have the potential for a "stuck icon". Doing a need info on Chris as he's been looking at a few of these issues recently. 

We also have a dragdrop patch to land I think, so we should check if the issues still reproduces after that patch.

Chris - any idea if this issue will reproduce after we land your patch?
Flags: needinfo?(chrislord.net)
I just ran across this but fixed it in a different way in a branch - Note, I still think disabling the home-button while dragging is something we should do anyway, so this looks good to me.

I'd find the icon getting stuck in these situations:
- We exit the edit mode during dragging
- The item detail index gets out of sync with the actual index (this happens if you modify placeholders/dividers outside of the render function)

I don't think the latter can happen anymore and this will stop the former for the most part (but it might possibly still occur if you lock the device during dragging?)

My patch here should fix that possible scenario, I think (yes, this should probably be split into two patches...): https://github.com/Cwiiis/gaia/commit/9759f3d1c284a63af4a474ba81eb5e0952167d5f
Flags: needinfo?(chrislord.net)
Comment on attachment 8442022 [details]
Github pull request

Ok, I agree with everything that's been said. I'd just like to have this one be reviewed by Chris because he's been touching the drag drop stuff a lot recently.

Chris - If you feel that this is still needed, and won't cause any problems with your patches, I'm fine with it. Thanks!
Attachment #8442022 - Flags: review?(kgrandon) → review?(chrislord.net)
Comment on attachment 8442022 [details]
Github pull request

Looks good to me.
Attachment #8442022 - Flags: review?(chrislord.net) → review+
Merged in master:

https://github.com/crdlc/gaia/commit/fd7cf4d2a140eccdc495fa952624b02e809352f0
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.0 S4 (20june)
Status: RESOLVED → VERIFIED
Attached video VIDEO0084_Compress.MP4
This issue has been successfully verified on Flame 2.0:
Gaia-Rev        8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/c756bd8bf3c3
Build-ID        20141130000204
Version         32.0
Device-Name     flame
FW-Release      4.4.2


This issue has been successfully verified on Flame 2.1:
Gaia-Rev        ccb49abe412c978a4045f0c75abff534372716c4
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/18fb67530b22
Build-ID        20141130001203
Version         34.0
Device-Name     flame
FW-Release      4.4.2
You need to log in before you can comment on or make changes to this bug.