[OPENC_1.3]No 'Sound' and 'Alert' selected in settings app any more after changing language.

RESOLVED FIXED

Status

P1
critical
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: zhang.ruili, Assigned: dkuo)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.3 affected, b2g-v2.0 affected, b2g-v2.1 fixed)

Details

Attachments

(4 attachments)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.153 Safari/537.36

Steps to reproduce:

1. Launch settings app and select “sound”.
2. Change 'Ringer', for example, to 'Classic Prism' and then tap done. Also, change 'Alert' sound.
3. Open 'Language' and change language to 'French' or any other language.
4. Reopen 'Sound' and 'Ringer' menu.

You'll find no any sound item selected, and so is 'Alert'.
(Reporter)

Updated

5 years ago
Severity: normal → critical
blocking-b2g: --- → 1.3?
OS: All → Gonk (Firefox OS)
Priority: -- → P1
Hardware: All → ARM
(Reporter)

Updated

5 years ago
Flags: needinfo?(vchen)

Comment 1

5 years ago
This issue has been reproduced with 1.3 buri (06/16) build:
Gecko-1da5885
Gaia-7f361e6

And also, with master (06/17) buri build:
Gecko-82463f1
Gaia-f93e6fa
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

5 years ago
Created attachment 8441243 [details]
English sound and alarm tones selected.png

Comment 3

5 years ago
Created attachment 8441244 [details]
Changed to French no sound or alarm selected.png
De-nom since it is not a critical bug to block 1.3.

Hi Howie, could you find someone to check this setting problem? It can be reproduced on master as well

Thanks
Flags: needinfo?(vchen) → needinfo?(hochang)
I would like to nominate the issue to be fixed in 2.0. Agree that we are late for 1.3.
blocking-b2g: 1.3? → 2.0?
status-b2g-v1.3: --- → affected
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → affected

Comment 6

5 years ago
This is something we should fix, but not a blocker, ni Dominic, can you help on this? Thanks.
blocking-b2g: 2.0? → ---
Flags: needinfo?(hochang) → needinfo?(dkuo)
(Assignee)

Comment 7

5 years ago
Created attachment 8444240 [details] [review]
patch

EJ,

This issue is a lack of the ringtones work from 2.0, the patch is trivial that added the missing l10nId, would you please review it? thanks.
Attachment #8444240 - Flags: review?(ejchen)
Flags: needinfo?(dkuo)
(Assignee)

Comment 8

5 years ago
Hey EJ,

Thanks for finding the issue that we found in the offline discussion, I have addressed it and now the custom ringtone should not be localized but keep as it is, would you review it again? thanks.
Flags: needinfo?(ejchen)
Domi, just left a comment on Github and please check it ! Thanks :)
Flags: needinfo?(ejchen)
(Assignee)

Comment 10

5 years ago
Thanks EJ and I have addressed the issue, mind to take a look again? thanks.
Flags: needinfo?(ejchen)
Comment on attachment 8444240 [details] [review]
patch

It looks nice ! r+

Thanks for the help, Domi !
Attachment #8444240 - Flags: review?(ejchen) → review+
(Assignee)

Comment 12

4 years ago
master: 9007d3846dd46e04b1ef8eed92bc482260206511
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-b2g-v2.1: affected → fixed
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Assignee: nobody → dkuo

Comment 13

4 years ago
Tested with unagi master and working OK. 

Gecko-0112de7
Gaia-512f288

Comment 14

4 years ago
Created attachment 8533080 [details]
VIDEO0155_Compress.MP4

This issue has been successfully verified on Flame 2.1:
Gaia-Rev        38e17b0219cbc50a4ad6f51101898f89e513a552
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/8b92c4b8f59a
Build-ID        20141205001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
You need to log in before you can comment on or make changes to this bug.