User can't see message when contacts are merged in import

VERIFIED FIXED in Firefox OS v2.0

Status

Firefox OS
Gaia::Contacts
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: lolimartinezcr, Assigned: Jose Manuel Cantera)

Tracking

unspecified
2.0 S4 (20june)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v1.3 affected, b2g-v2.0 verified, b2g-v2.1 verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
User can't see message when contacts are merged in import

Tested
Hamachi
2.1
Gecko: a3c4c53
Gaia: 5f9f64a

Reproducible 100%

Pre-requisites: Contacts created  in Memory card with same name, surname and phone number other contact created in mobile phone
 
STRs:
1. Tap contacts application.
2. Tap settings option.
3. Tap import contacts option.
4. Tap "Memory card" button.

Expected result:
All contacts are imported and a contact merged. User can see message about number of contact imported and merged.

Actual result: 
All contacts are imported and a contact merged. User can see message about number of contact imported and *NOT* merged.
(Assignee)

Updated

3 years ago
Assignee: nobody → jmcf
(Reporter)

Comment 1

3 years ago
(In reply to Loli from comment #0)
> User can't see message when contacts are merged in import
> 
> Tested
> Hamachi
> 2.1
> Gecko: a3c4c53
> Gaia: 5f9f64a
> 
> Reproducible 100%
> 
> Pre-requisites: Contacts created  in Memory card with same name, surname and
> phone number other contact created in mobile phone
>  
> STRs:
> 1. Tap contacts application.
> 2. Tap settings option.
> 3. Tap import contacts option.
> 4. Tap "Memory card" button.
> 
> Expected result:
> All contacts are imported and a contact merged. User can see message about
> number of contact imported and merged.
> 
> Actual result: 
> All contacts are imported and a contact merged. User can see message about
> number of contact imported and *NOT* merged.


Where I say "Memory card", it should say "SIM card"
(Assignee)

Comment 2

3 years ago
Created attachment 8441226 [details]
20598.html
Attachment #8441226 - Flags: review?(francisco)
Attachment #8441226 - Flags: review?(francisco) → review+
(Assignee)

Comment 3

3 years ago
https://github.com/mozilla-b2g/gaia/commit/991221123c252465b11c5a8871aa1fa8b909df0b
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Keywords: verifyme
QA Contact: lolimartinezcr
Blocks: 977528
Nominating to 2.0, as it's a bug in the feature Bug 977528 "[Contacts][Feature] Importers should give information of automated merged contacts" already landed in 2.0
blocking-b2g: --- → 2.0?

Updated

3 years ago
blocking-b2g: 2.0? → 2.0+
v2.0: https://github.com/mozilla-b2g/gaia/commit/0ad31893b31fbe8fdc3c8bb221810f4f877a74c6
status-b2g-v2.0: --- → fixed
status-b2g-v2.1: --- → fixed
Target Milestone: --- → 2.0 S4 (20june)
(Reporter)

Comment 6

3 years ago
Tested and working
Hamachi
2.1
Gecko-57d05d4
Gaia-846f561

Pending build 2.0
Duplicate of this bug: 1028844
status-b2g-v1.3: --- → affected
(Reporter)

Comment 8

3 years ago
Tested and working
Hamachi
2.0
Gecko-c91e987
Gaia-87d0463
Status: RESOLVED → VERIFIED

Comment 9

3 years ago
verify with Flame KK v180 + v2.0 gaia/gecko, it's fine
Gaia      7edd3b0b9f65c3dde235c732d270e43e055a1254
Gecko     https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/13e04ab68621
BuildID   20140914162307
Version   32.0
Keywords: verifyme

Comment 10

3 years ago
This issue has been verified successfully on Flame2.0&2.1
Verify video:"verify_1026370.mp4".

Flame2.0 build
Gaia-Rev        824a61cccec4c69be9a86ad5cb629a1f61fa142f
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/acde07cb4e4d
Build-ID        20141125040209
Version         36.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141125.113029
FW-Date         Tue Nov 25 11:30:43 EST 2014
Bootloader      L1TC00011880

Flame2.1 build:
Gaia-Rev        db2e84860f5a7cc334464618c6ea9e92ff82e9dd
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/211eae88f119
Build-ID        20141126001202
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141126.033519
FW-Date         Wed Nov 26 03:35:30 EST 2014
Bootloader      L1TC00011880
status-b2g-v2.0: fixed → verified
status-b2g-v2.1: fixed → verified

Comment 11

3 years ago
Created attachment 8529520 [details]
Verifid video: verify_1026370.mp4.MP4
You need to log in before you can comment on or make changes to this bug.