[Flame[v2.1] test_setup_and_send_active_sync_email is intermittently failing

RESOLVED FIXED

Status

Firefox OS
Gaia::UI Tests
P1
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: AndreiH, Assigned: AndreiH)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Assignee)

Description

4 years ago
Created attachment 8441225 [details]
download.png

The last fail occurred in:

http://selenium.qa.mtv2.mozilla.com:8080/view/B2G%20Flame/job/b2g.flame.mozilla-central.ui.smoketest/73/HTML_Report/

Traceback (most recent call last):
  File "/var/jenkins/workspace/b2g.flame.mozilla-central.ui.smoketest/.env/local/lib/python2.7/site-packages/marionette_client-0.7.9-py2.7.egg/marionette/marionette_test.py", line 170, in run
    testMethod()
  File "/var/jenkins/workspace/b2g.flame.mozilla-central.ui.smoketest/tests/python/gaia-ui-tests/gaiatest/tests/functional/email/test_setup_and_send_active_sync_email.py", line 30, in test_setup_and_send_active_sync_email
    self.email.setup_active_sync_email(self.account)
  File "/var/jenkins/workspace/b2g.flame.mozilla-central.ui.smoketest/tests/python/gaia-ui-tests/gaiatest/apps/email/app.py", line 78, in setup_active_sync_email
    setup.check_for_emails_interval('20000')
  File "/var/jenkins/workspace/b2g.flame.mozilla-central.ui.smoketest/tests/python/gaia-ui-tests/gaiatest/apps/email/regions/setup.py", line 160, in check_for_emails_interval
    self.select('Every 5 minutes')
  File "/var/jenkins/workspace/b2g.flame.mozilla-central.ui.smoketest/tests/python/gaia-ui-tests/gaiatest/apps/base.py", line 98, in select
    self.wait_for_element_not_displayed(*_close_button_locator)
  File "/var/jenkins/workspace/b2g.flame.mozilla-central.ui.smoketest/tests/python/gaia-ui-tests/gaiatest/apps/base.py", line 48, in wait_for_element_not_displayed
    lambda m: not m.find_element(by, locator).is_displayed())
  File "/var/jenkins/workspace/b2g.flame.mozilla-central.ui.smoketest/.env/local/lib/python2.7/site-packages/marionette_client-0.7.9-py2.7.egg/marionette/wait.py", line 143, in until
    cause=last_exc)
TimeoutException: TimeoutException: Timed out after 20.1 seconds
(Assignee)

Updated

4 years ago
Assignee: nobody → andrei.hutusoru
Priority: -- → P1
(Assignee)

Comment 1

4 years ago
This needs more investigation
(Assignee)

Comment 2

4 years ago
Created attachment 8441247 [details]
VIDdeo.3gp

This video explains why this is failing.
Tapping on ok is done to quickly.

At these steps: https://github.com/mozilla-b2g/gaia/blob/master/tests/python/gaia-ui-tests/gaiatest/apps/base.py#L93

Comment 3

4 years ago
Weird, that's usually quite stable..
Put a wait for <li> to == selected ?
(Assignee)

Comment 4

4 years ago
We can use something like this for this test Zac, but there are a lot of other tests that use the "select" method that maybe don't have the "selected" attribute .

Should we ask the devs for some improvement?
Flags: needinfo?(zcampbell)

Comment 5

4 years ago
It's a global/shared feature in the System app so I shouldn't think you'll regress anything by adding that wait in there.
Flags: needinfo?(zcampbell)
(Assignee)

Comment 6

4 years ago
Created attachment 8441325 [details]
2014-06-17-15-07-11.png

After some more investigation I see that when the test fails, the keyboards is still displayed. (see the screenshot)
(Assignee)

Comment 7

4 years ago
Created attachment 8441328 [details] [review]
PR https://github.com/mozilla-b2g/gaia/pull/20614
Attachment #8441328 - Flags: review?(zcampbell)
Attachment #8441328 - Flags: review?(florin.strugariu)
Should that be visible?
Comment on attachment 8441328 [details] [review]
PR https://github.com/mozilla-b2g/gaia/pull/20614

I tried to reproduce this but I couldn't

I could reproduce it if we run automated tests multiple times

It looks like somehow the keyboard suggestions take a little longer to load and we go to the next step and don't wait for the keyboard to dismiss this makes the keyboard visible over the screen  

The patch prevents this to happen
Attachment #8441328 - Flags: review?(florin.strugariu) → review+

Comment 12

4 years ago
Merged:
https://github.com/mozilla-b2g/gaia/commit/2cb9af38a933d531aaf27ffc19910f17e5931d2d
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.