[Error] Can't print to XPS - Printer Error - An error occurred while printing

NEW
Unassigned

Status

()

Core
Printing: Output
4 years ago
3 months ago

People

(Reporter: Gingerbread Man, Unassigned)

Tracking

({regression})

Trunk
x86_64
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [parity-ie])

(Reporter)

Description

4 years ago
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
Built from https://hg.mozilla.org/mozilla-central/rev/80431d4fd0da

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 SeaMonkey/2.26.1
Built from http://hg.mozilla.org/releases/mozilla-release/rev/af7d521d4fb3

1. Go to https://en.wikipedia.org/w/index.php?title=Main_Page&printable=yes
2. Click the Menu Button, then the Print button.
3. Click the Print… button.
4. Select "Microsoft XPS Document Writer" as the printer, then click the OK button.
5. Type a filename, e.g. filename.xps, then click the Save button.

A dialog box pops up saying
[ Printer Error ]
An error occurred while printing.

No problems when printing from Internet Explorer 11.
(Reporter)

Comment 1

4 years ago
Firefox 4.0.1 works.
Built from http://hg.mozilla.org/releases/mozilla-2.0/rev/fca718600ca0

Firefox 5.0 beta 1 doesn't work.
Built from http://hg.mozilla.org/mozilla-beta/rev/9df9078bc469
Keywords: regression
(Reporter)

Comment 2

3 years ago
There's a new development that has me completely confused.

WORKS:
37.0.1 in my regular profile, provided that “Print Background (colors & images)” is checked. I also tried Safe Mode, which rules out add-ons and leaves a difference in preferences as the only likely explanation.

FAILS:
37.0.1 in a brand new profile. Checking “Print Background (colors & images)” makes no difference. I also compared the print.printer_Microsoft_XPS_Document_Writer.* preferences and set the differing ones to match those in the regular profile. It didn't help. The regular print.* preferences are all at their default values in both profiles.

Comment 3

3 years ago
Similar problem happens on windows 10. Edge can print page into pdf using Print to PDF but firefox can't and always says "You have no right to store files here"

Comment 4

a year ago
Try resetting "nullifying" the key "security.sandbox.content.tempDirSuffix" in about:config.

Let me know if that fixes it.  If it does, this is a bug that can be traced and fixed.

Thanks.

- Kev
(Reporter)

Comment 5

a year ago
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0

Resetting security.sandbox.content.tempDirSuffix doesn't fix the problem, even after restarting.
What paper size is selected when you try to print?
Summary: Can't print to XPS - Printer Error - An error occurred while printing → [Error] Can't print to XPS - Printer Error - An error occurred while printing
(Reporter)

Comment 7

3 months ago
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
20180118012136

Letter.
I just tried printing in Vivaldi 1.13.1008.34 32-bit and it worked.
You need to log in before you can comment on or make changes to this bug.