Closed Bug 1026588 Opened 5 years ago Closed 5 years ago

[B2G][Marketplace]app icons are very low res in homescreen unless app is in featured app list

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.0+)

VERIFIED WORKSFORME
blocking-b2g 2.0+

People

(Reporter: rkuhlman, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [2.0-daily-testing][systemsfe])

Attachments

(1 file)

Attached image marketplaceicons.png
Apps downloaded from the marketplace have very low res icons in the homescreen. If the app is a featured app, the icon displays in a higher, but still low resolution

1) Update a Flame to BuildID: 20140617000201
2) Launch Marketplace
3) Download an app from the featured app list
4) Download an app from the regular marketplace
5) Observe app icons in marketplace.

Actual:
App icon from step 4 is very low res. App icon from step 3 is slightly low res

Expected:
All app icons display in the same resolution

v2.0 Environmental Variables:
Device: Flame v2.0 MOZ
BuildID: 20140617000201
Gaia: 0f254c92bc44d614ae56a855f18a895a7e4703ad
Gecko: 7f309a3a4d3d
Version: 32.0a2
Firmware Version: v121-2


Notes:
Repro frequency: 100%
See attached: screenshot
adding qawanted to determine if issue occurs on 1.4 and Master
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
Whiteboard: [2.0-daily-testing]
Flags: needinfo?(jmitchell)
Will wait for QA Wanted here, but I'm pretty sure this isn't present with the old homescreen. We're going to need to get this fixed too.
Marketplace icons all display at the appropriate resolution in v1.4. Issue does not repro.
Device: Flame v1.4
BuildID: 20140617000202
Gaia: 4b3428e85b428e577a0f96cba6121c4ca1c91f8a
Gecko: ba55b5a7b20d
Version: 30.0
Firmware Version: v121-2

Marketplace app icons all display appropriately in v2.1(Master) build. Unable to repro.
Device: Flame Master M/C MOZ
BuildID: 20140617040203
Gaia: eac13407742a55b11e1877b4df2abdfd22cd582ecd 
Gecko: bb35d1b73634
Version: 33.0a1
Firmware Version: v121-2

Marketplace app icons display in low resolution on the latest Buri v2.0
Device: Buri v2.0 MOZ
BuildID: 20140617000201
Gaia: 0f254c92bc44d614ae56a855f18a895a7e4703ad
Gecko: 7f309a3a4d3d
Version: 32.0a2
Firmware Version: v1.2-device.cfg

adding regression tags
Parity issue when moving to the vertical homescreen, so we need to block on this.
Blocks: 1015336
No longer blocks: vertical-homescreen
blocking-b2g: --- → 2.0?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage?][VH-FL-blocking-][VH-FC-blocking+]
blocking-b2g: 2.0? → 2.0+
QA Whiteboard: [QAnalyst-Triage?][VH-FL-blocking-][VH-FC-blocking+] → [QAnalyst-Triage+][lead-review+][VH-FL-blocking-][VH-FC-blocking+]
Whiteboard: [2.0-daily-testing] → [2.0-daily-testing][systemsfe]
Can you check if this happens if the homescreen is configured to render 4 rows instead of 3 ? (You can do that from Settings -> Homescreen).

I suspect that the issue is that those apps in marketplace only have a 60px icons, and not a bigger icons as needed by the new homescreen app on for 3 icons by rows.

If that's the case, this bug is more an evangelism bug where the apps on the marketplace needs to be updated - and this means that those can be updated between now and when the device is on the market, and should not be FC.
blocking-b2g: 2.0+ → 2.0?
Keywords: qawanted
(In reply to Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) from comment #5)
> Can you check if this happens if the homescreen is configured to render 4
> rows instead of 3 ? (You can do that from Settings -> Homescreen).
> 
> I suspect that the issue is that those apps in marketplace only have a 60px
> icons, and not a bigger icons as needed by the new homescreen app on for 3
> icons by rows.
> 
> If that's the case, this bug is more an evangelism bug where the apps on the
> marketplace needs to be updated - and this means that those can be updated
> between now and when the device is on the market, and should not be FC.

I don't think we can push the blame on evangelism here. If we are imposing a new homescreen which requires a different icon size requirement & the large majority of apps don't support it, then we can't support that column amount right now. Marketplace does place a requirement on icon size for one particular icon size though, so we have to be able to handle that case as the smallest icon size in the 3 column view. On that regard, this remains as a blocker that has to be solved within the vertical homescreen itself, since the icon size requirements for apps in marketplace is well known & must be followed in a design of a homescreen app.
blocking-b2g: 2.0? → 2.0+
Keywords: qawanted
Actually I am fairly sure this was due to the same bug for the other "fuzzy icon" bugs that we had. Appears that we may have been choosing the lowest resolution icon.

Unfortunately I'm not sure which cset fixed this, as we uplifted 20+ bugs over the weekend. Please let me know if you are still seeing this problem.
Status: NEW → RESOLVED
Closed: 5 years ago
Keywords: verifyme
Resolution: --- → WORKSFORME
(In reply to Jason Smith [:jsmith] from comment #6)
> (In reply to Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails,
> needinfo? please) from comment #5)
> > Can you check if this happens if the homescreen is configured to render 4
> > rows instead of 3 ? (You can do that from Settings -> Homescreen).
> > 
> > I suspect that the issue is that those apps in marketplace only have a 60px
> > icons, and not a bigger icons as needed by the new homescreen app on for 3
> > icons by rows.
> > 
> > If that's the case, this bug is more an evangelism bug where the apps on the
> > marketplace needs to be updated - and this means that those can be updated
> > between now and when the device is on the market, and should not be FC.
> 
> I don't think we can push the blame on evangelism here. If we are imposing a
> new homescreen which requires a different icon size requirement & the large
> majority of apps don't support it, then we can't support that column amount
> right now. Marketplace does place a requirement on icon size for one
> particular icon size though, so we have to be able to handle that case as
> the smallest icon size in the 3 column view. On that regard, this remains as
> a blocker that has to be solved within the vertical homescreen itself, since
> the icon size requirements for apps in marketplace is well known & must be
> followed in a design of a homescreen app.

Blockers means it blocks FC. Between FC and release there is a vast amount of time, that can be used by the Marketplace folks to evangelize the appsm and so the apps can be updated independently of the image on the device.
That said, Kevin says that may be something else - good thing.
Verified. This issue no longer occurs on Flame 2.0.
App icons from the Marketplace all appear in a proper, high resolution.

Environmental Variables:
Device: Flame 2.0
BuildID: 20140912000202
Gaia: 91dd0e596aa7c124dd968e1474b23e7992dc35a1
Gecko: a66168598533
Version: 32.0 (2.0)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][lead-review+][VH-FL-blocking-][VH-FC-blocking+] → [QAnalyst-Triage?][lead-review+][VH-FL-blocking-][VH-FC-blocking+]
Flags: needinfo?(pbylenga)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?][lead-review+][VH-FL-blocking-][VH-FC-blocking+] → [QAnalyst-Triage+][lead-review+][VH-FL-blocking-][VH-FC-blocking+]
Flags: needinfo?(pbylenga)
You need to log in before you can comment on or make changes to this bug.