PDF partially displayed in pdf.js

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: augustmiles, Unassigned)

Tracking

31 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pdfjs])

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140610163407

Steps to reproduce:

1) restart in safe mode
2) go to link http://www.tiro.com/Maxwell/Maxwell_beta_1.5_spec.pdf
3) wait for the pdf viewer to startup


Actual results:

In Firefox(beta)-31: The viewing region remains black, one can download and view the pdf  using the usual mac pdf viewer. There are three pages.

In Firefox-29: The first and third pages can been seen in the viewer, but the second
page has a "spinner" which turns for minutes without result. Again the pdf can
be opened in the native viewer

Thus 31 is worse than 29


Expected results:

The three pages should be visible using the firefox viewer.
Hi,

I wasn't able to reproduce with latest Nightly Firefox/33.0 ID:20140617030203 on Linux x86_64: the document took quite a bit to load, but it did it completely. Disabling the hardware acceleration made it faster to load.


Could you please try if the problem occurs also with hardware acceleration off? (you can follow this instructions to do it → https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems#w_turn-off-hardware-acceleration ).

Cheers,
Francesca
Component: Untriaged → PDF Viewer
Flags: needinfo?(augustmiles)

Comment 2

4 years ago
I tried on Windows 7.
Beta 31 loaded it ok and Nightly 33 ok as well.
(Reporter)

Comment 3

4 years ago
More information--

The original try was on a recent Imac (21.5-inch, Late 2013, 10.9.3),
I tried on a macbook air - the page rendered.

1) I turned off the acceleration on the Imac.

2) Out of five tries (with a restart between the tries)
 the three pages rendered fully just once.

3) It is now intermittently either the second or the third page which is not rendering.
Flags: needinfo?(augustmiles)
Couldn't reproduce on an iMac with 10.8.5 in normal or safe mode start: the pdf is loaded completely, it takes 5 to 7 seconds to be fully loaded.

Comment 5

4 years ago
This might be related to https://bugzilla.mozilla.org/show_bug.cgi?id=1026488
I could not reproduce this with 10.8.5 and Firefox 31.0b, the 20140616143923 build. 

This probably needs confirming on Mac OSX 10.9.
Whiteboard: [pdfjs] [qa+]
Same results as stated in comment 4 on FF31b3 under Mac OSX 10.9.3.

Am, does it work now that bug 1026400 is fixed?
Flags: needinfo?(augustmiles)
Whiteboard: [pdfjs] [qa+] → [pdfjs]
(Reporter)

Comment 8

4 years ago
Alternated between FF29, and nightly (33) half a dozen times. FF29 is always broken, 
Nightly works perfectly...

So it seems to be fixed somewhere,  bug 1026400 is too technical for me to say if
this is the reason
Flags: needinfo?(augustmiles)
Thanks AM!
Marking as RWFM if it works good for you on Nightly and nobody else encountered the issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.