[B2G][2.0][Flame][Vertical Homescreen] Unable to delete the only divider remaining

RESOLVED DUPLICATE of bug 1026082

Status

Firefox OS
Gaia::Homescreen
RESOLVED DUPLICATE of bug 1026082
4 years ago
4 years ago

People

(Reporter: YeojinC, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected)

Details

(Whiteboard: [2.0-flame-test-run-2])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8441515 [details]
DividerRemaining.png

Description: 
The only divider remaining does not disappear when the user moves all icons to the first group.

Prerequisite: The vertical homescreen should contain 1 group of 1 icon at least and 1 group (i.e.: some icons, 1 divider, 1 icon).

Repro Steps:
1) Update a Flame to 20140616063005.
2) On the homescreen, enter edit mode (by long pressing an icon).
3) Drag and drop the icon from the last group to the first group.
4) Verify that there are no more dividers.

Actual:
The divider is shown at the end of the screen.

Expected:
There is no more divider on the screen.

Environmental Variables:
Device: Flame 2.0
Build ID: 20140616000203
Gaia: a6988c15b361938bea5976c846c147ecdc1121c0
Gecko: 52a276202888
Version: 32.0a2 (2.0) 
Firmware Version: v121-2
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0 

Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/13096/
See attached: logcat, screenshot
(Logcat is used on Open C. See https://bugzilla.mozilla.org/show_bug.cgi?id=1010993)

--------------------------------------------------------------------------------------
The issue DOES occur on Flame v.2.1. The divider is shown at the end of the screen when there is only 1 group remaining:

Environmental Variables:
Device: Flame 2.1 - Master
Build ID: 20140616040202
Gaia: dfc4703bb81d1fa4f2087a1a6124b47a80a5d1de
Gecko: 80431d4fd0da
Version: 33.0a1 (2.1 - Master) 
Firmware Version: v121-2
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

---------------------------------------------------------------------
This issue DOES occur on Open C v.2.0. The divider is shown at the end of the screen when there is only 1 group remaining:

Environmental Variables:
Device: Open_C 2.0
Build ID: 20140612000201
Gaia: 2bb66630315299ca947e40fcec23c9f7ea012111
Gecko: 670d69879f0e
Version: 32.0a2 (2.0)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
---------------------------------------------------------------------
This issue DOES occur on Buri v.2.0. The divider is shown at the end of the screen when there is only 1 group remaining:

Environmental Variables:
Device: Buri 2.0
Build ID: 20140616063005
Gaia: a6988c15b361938bea5976c846c147ecdc1121c0
Gecko: f2413cf1965e
Version: 32.0a2 (2.0) 
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
---------------------------------------------------------------------
This feature did not exist prior to v.2.0. Unable to Reproduce on v.1.4:

Environmental Variables:
Device: Flame 1.4
Build ID: 20140616000202
Gaia: 164644d91290708a71436dfdf4301e33b92e2c77
Gecko: 2949e8bef869
Version: 30.0 (1.4) 
Firmware Version: v121-2
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → affected
Flags: needinfo?(ktucker)
(Reporter)

Comment 1

4 years ago
Created attachment 8441517 [details]
logcat_20140617_LastDivider.txt
Does this issue occur on the Buri and Open C Master?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage-]
Flags: needinfo?(ktucker) → needinfo?(ychung)
(Reporter)

Comment 3

4 years ago
This issue reproduces on Flame 2.1 and Buri 2.1:

Environmental Variables:
Device: Buri 2.1 - Master
Build ID: 20140615103005
Gaia: dfc4703bb81d1fa4f2087a1a6124b47a80a5d1de
Gecko: 80431d4fd0da
Version: 33.0a1 (2.1 - Master) 
Firmware Version: v1.2device.cfg

Environmental Variables:
Device: Flame 2.1 - Master
Build ID: 20140616040202
Gaia: dfc4703bb81d1fa4f2087a1a6124b47a80a5d1de
Gecko: 80431d4fd0da
Version: 33.0a1 (2.1 - Master)
Firmware Version: v121-2
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0 

Actual result: The divider is shown at the end of the screen when there is only 1 group remaining.
Flags: needinfo?(ychung) → needinfo?(ktucker)
(Reporter)

Comment 4

4 years ago
Please disregard comment 3. Here's the correct info:

This issue reproduces on Open C 2.1 and Buri 2.1:

Environmental Variables:
Device: Open_C Master
Build ID: 20140616040202
Gaia: dfc4703bb81d1fa4f2087a1a6124b47a80a5d1de
Gecko: 80431d4fd0da
Version: 33.0a1 (Master) 
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Environmental Variables:
Device: Buri 2.1 - Master
Build ID: 20140615103005
Gaia: dfc4703bb81d1fa4f2087a1a6124b47a80a5d1de
Gecko: 80431d4fd0da
Version: 33.0a1 (2.1 - Master) 
Firmware Version: v1.2device.cfg

Actual result: The divider is shown at the end of the screen when there is only 1 group remaining.
Buri master - User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0
QA Whiteboard: [QAnalyst-Triage-] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)

Updated

4 years ago
Blocks: 1015336
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][VH-FL-blocking-][VH-FC-blocking-]

Updated

4 years ago
Component: Gaia → Gaia::Homescreen

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+][VH-FL-blocking-][VH-FC-blocking-] → [QAnalyst-Triage+][lead-review+][VH-FL-blocking-][VH-FC-blocking-]

Updated

4 years ago
Blocks: 1017954
No longer blocks: 1015336
(Reporter)

Updated

4 years ago
Blocks: 1027284
(Reporter)

Updated

4 years ago
No longer blocks: 1027284

Updated

4 years ago
No longer blocks: 1017954
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1026082
You need to log in before you can comment on or make changes to this bug.