Uplift tbpl fixes in firefox33 branch to firefox32 branch of the addon-sdk repo

RESOLVED FIXED in Firefox 32

Status

Add-on SDK
General
P1
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: erikvold, Assigned: erikvold)

Tracking

unspecified
mozilla32
Dependency tree / graph

Firefox Tracking Flags

(firefox32 fixed, firefox33 fixed)

Details

(URL)

Attachments

(1 attachment)

Comment hidden (empty)
Blocks: 1020458, 1020463
https://github.com/mozilla/addon-sdk/compare/cda08d6eb506...4db3254f04c9
https://tbpl.mozilla.org/?tree=Try&rev=074590aff768
Assignee: nobody → evold
Depends on: 1024837
What's the process for uplifting this diff?
Flags: needinfo?(ryanvm)
Created attachment 8441769 [details] [diff] [review]
1026636.patch

I'm not sure who to ask for a review to uplift this.
Attachment #8441769 - Flags: review?(dtownsend+bugmail)
Blocks: 1020473
Since this affects non-test code, you'll need to request Aurora approval on the patch and fill out the form it gives you.
Flags: needinfo?(ryanvm)
And once approved, you do the normal SDK uplift process, but you use the SDK's firefox32 branch, and you push it to Firefox's mozilla-aurora branch.
(In reply to Wes Kocher (:KWierso) from comment #6)
> And once approved, you do the normal SDK uplift process, but you use the
> SDK's firefox32 branch, and you push it to Firefox's mozilla-aurora branch.

I did this and tried the patch over at https://tbpl.mozilla.org/?tree=Try&rev=074590aff768  I'm pretty sure those failures are unrelated too.
Comment on attachment 8441769 [details] [diff] [review]
1026636.patch

Uplifts don't need review, they do need approvals though, follow the process in comment 5.
Attachment #8441769 - Flags: review?(dtownsend+bugmail)
Comment on attachment 8441769 [details] [diff] [review]
1026636.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 1020458 and bug 1020463 
User impact if declined: None
Testing completed (on m-c, etc.): fx-tree and m-c
Risk to taking this patch (and alternatives if risky): None, this is all test code
String or IDL/UUID changes made by this patch: Not sure what this is.
Attachment #8441769 - Flags: approval-mozilla-aurora?
Priority: -- → P1
status-firefox32: --- → affected
status-firefox33: --- → fixed
Comment on attachment 8441769 [details] [diff] [review]
1026636.patch

We like tests. Taking it for 32.
Attachment #8441769 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/ebff751502d3

*fingers crossed*
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-firefox32: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla32
You need to log in before you can comment on or make changes to this bug.