[B2G][APZ]Dragging brightness slider upwards results in blank screen until finger is released

RESOLVED DUPLICATE of bug 1023506

Status

()

Core
Panning and Zooming
RESOLVED DUPLICATE of bug 1023506
4 years ago
4 years ago

People

(Reporter: Ross Kuhlman (rkuhlman@qanalydocs.com), Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected)

Details

(Whiteboard: [2.0-daily-testing])

Attachments

(1 attachment)

Created attachment 8441585 [details]
brightnessSliderGallery.txt

In Gallery edit picture mode, after dragging the brightness slider left and right a few times, the user can drag the slider upwards resulting in a blank screen. The screen will remain blank until the slider is dragged back below the the slider line, or user stops touching the screen. 

Repro Steps:
1) Update a Flame to BuildID: 20140617040203
2) Launch Gallery
3) Begin editing an image
4) Drag the brightness slider left and right rapidly
5) Drag slider upwards
6) Repeat steps 4 and 5 as necessary. Once blank screen issue occurs, it occurs 100% of the time

Actual:
Dragging slider upwards causes screen to go blank

Expected:
dragging slider upwards does nothing

Master M/C Environmental Variables:
Device: Flame Master M/C MOZ
BuildID: 20140617040203
Gaia: eac13407742a55b11e1877b4df2abdfd22cd582e
Gecko: bb35d1b73634
Version: 33.0a1
Firmware Version: v121-2

Notes:
The scrubber on the brightness slider looks truncated on top/bottom

Video: https://www.youtube.com/watch?v=4OPswaCatBM&edit=vd

Repro frequency: 100%
See attached: video, logcat
qawanted to determine if issue occurs on 1.4 and 2.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
Whiteboard: [2.0-daily-testing]
Flags: needinfo?(jmitchell)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]

Comment 2

4 years ago
Issue also occurs in the 'Smart Collection' if the results can be scrolled.

1. Select the 'Music' collection
2. Wait for the page to fully load
3. Scroll downward on the screen

This issue does NOT occur in either location with APZ turned off.

Environmental Variables:
Device: Flame
Build ID: 20140625000201
Gaia: de77f794db22a45f9d575de2c6e266a30a50de3b
Gecko: 79712bd7b60d
Version: 32.0a2 (2.0) 
Firmware Version: v122
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → affected
Component: Gaia::Gallery → Panning and Zooming
Product: Firefox OS → Core
Summary: [B2G][Gallery][Edit]Dragging brightness slider upwards results in blank screen until finger is released → [B2G][APZ]Dragging brightness slider upwards results in blank screen until finger is released
Bug 1029971 is tracking the issue in the smart collections. Let's leave this bug about comment 0 only.
This is actually a dupe of bug 1023506 with slightly different STR but the same underlying cause. I'll leave it as a dependency for now, but will dupe once that's landed and we've verified this is fixed too.
Depends on: 1023506
Status: NEW → RESOLVED
Last Resolved: 4 years ago
No longer depends on: 1023506
Resolution: --- → DUPLICATE
Duplicate of bug: 1023506

Updated

4 years ago
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.