Closed Bug 1026689 Opened 6 years ago Closed 6 years ago

Reduce empty Spaces in apps

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

x86
macOS
defect
Not set

Tracking

(feature-b2g:2.1, tracking-b2g:backlog, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S3 (29aug)
feature-b2g 2.1
tracking-b2g backlog
Tracking Status
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: wmathanaraj, Assigned: arcturus)

References

Details

(Keywords: feature, meta, Whiteboard: [tako][2.1-feature-qa+])

User Story

As a user I want empty spaces in applications to be handled better so I am not left feeling as if some information is missing on the screen.

AC1: minimise the empty space in the design of the apps
No description provided.
blocking-b2g: --- → backlog
feature-b2g: --- → 2.1
User Story: (updated)
Keywords: feature
Whiteboard: [tako]
Hi Wilfred... 

Are you able to provide more details on this user story? We just reviewed the bug with the Frameworks team and we're not clear on the scope / nature of the issue.

- Rob
Flags: needinfo?(wmathanaraj)
About this user story, I did some evaluation and figure out we should provide default photos for those contacts who don't have profile pictures. It leaves a lot of spaces on the layout and looks kind of weird. I'd like to know whether do we have this visual proposal for our OS? 

ni?Patryk for confirmation. Thanks!
Flags: needinfo?(padamczyk)
We have started working on a proposal, but its a system wide project involving dialer, contacts and media, I don't see this realistically for v.2.1

Is this user story, really for blank contacts? I believe we need more info from whoever requested this.
Flags: needinfo?(padamczyk)
the user story is vague on purpose as the request is to look at the apps make changes that will be doable in 2.1 and then make changes that will be doable in 2.2. not ne single lot of changes that will be too big for any release.

the request focuses on core apps such as contacts, email, calendar and dialer. Media is of interest if you want to make changes to them as well.

there is no specific bugs to fix but this is for the UX team to lake a look at the look and feel of the app and make changes.

if we have only ability to make changes in contacts app then fine we can just start with this. But we need a UX proposal that we can take to partners and discuss what is coming next that works in a iterative manner.
Flags: needinfo?(wmathanaraj)
See Also: → 1038714
QA Contact: echang
QA Whiteboard: [Gaia::Contacts]
QA Whiteboard: [Gaia::Contacts] → [COM=Gaia::Contacts]
Depends on: 1043496
This bug is a bit confusing for me, what are we trying to achieve, the FTE of each app? Also there is a blocker related to default images.

Is this a meta bug? In case of that, what are the actions that are going to be solving here for any app.

Remember this has been named as a high priorty tako feature.

Wilfred are you the one saying what features are we going to implement here?
Flags: needinfo?(wmathanaraj)
there are some specs already done by carrie which address these items. We have also discussed this and agreed that this addresses what needs to be done for this bug.
Flags: needinfo?(wmathanaraj)
Nice,

Carrie do we have bugs for those specs that we can put as blockers of this bug?
Flags: needinfo?(cawang)
For the empty space issue in Contacts, we think that might be the the default photos for those contacts who don't have profile pictures. The visual team has been working on this and from comment 3, seems like it will not happen in 2.1. Hence, I don't think we have any spec yet.

The other user story (the actionable fields) has similar situation and I've done some spec to improve it. Please check the meta bug 1043166. I think we can focus this one in 2.1 since it's more about interaction and only happening in Contacts APP. Thanks!
Flags: needinfo?(cawang)
Thanks for the clarification Carrie!
QA Whiteboard: [COM=Gaia::Contacts] → [COM=Gaia::Contacts][2.1-feature-qa+]
Hi Wilfred,
Per comment 3 and comment 8, it seems there's no clear action at this moment for 2.1.
Should we remove the feature-b2g flag?
Flags: needinfo?(wmathanaraj)
i will talk to the partner to understand more than what we have already done - Ince confirmed I will remove the flags.
Flags: needinfo?(wmathanaraj)
Wilfred, the soon we know that the soon we will know if this will fit on 2.1

Pavel is advancing on the work, so if the scope for 2.1 is just bug 1043496 and bug 1043166, we should be on track.

;)
Flags: in-moztrap?(echang)
QA Whiteboard: [COM=Gaia::Contacts][2.1-feature-qa+] → [COM=Gaia::Contacts]
Whiteboard: [tako] → [tako][2.1-feature-qa+]
QA Contact: echang → jlorenzo
Flags: in-moztrap?(echang) → in-moztrap?(jlorenzo)
As per comment 12, this bug seems to be a meta for bug 1043496 and bug 1043166 at the moment. Let's track the test cases there.

If the scope grew, please flip again the in-moztrap flag to ?.
Flags: in-moztrap?(jlorenzo) → in-moztrap-
(In reply to Johan Lorenzo [:jlorenzo] from comment #13)
After discussing offline with Jason, I will flip the in-moztrap flag to + once the 2 bugs are done. This allows tracking in this high-level dashboard: https://wiki.mozilla.org/B2G/QA/Tako_Tracking
Flags: in-moztrap- → in-moztrap?(jlorenzo)
Hey Wesley, 

I don't see this in progress or updated with a target milestone.  Has this started? Is it a sprint 3 target?

Thanks,
Candice
Flags: needinfo?(whuang)
Hi Candice,
Per my offline discussion with Wilfred, Bug 1043496 fulfill this user story as in 2.1.
I think we can RESOLVE FIXED the bug once Bug 1043496 lands.
Flags: needinfo?(whuang)
Assignee: nobody → francisco
Target Milestone: --- → 2.1 S3 (29aug)
Coverage done in the dependent bug: Bug 1043496 comment 44
Flags: in-moztrap?(jlorenzo) → in-moztrap-
Flags: in-moztrap- → in-moztrap+
Marking as fixed, since the taskt for 2.1 that we had was the default images.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
QA Whiteboard: [COM=Gaia::Contacts] → [COM=Gaia::Contacts][QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Status: RESOLVED → VERIFIED
QA Whiteboard: [COM=Gaia::Contacts][QAnalyst-Triage?] → [COM=Gaia::Contacts][QAnalyst-Triage+]
Flags: needinfo?(ktucker)
This issue is verified fixed on Flame 2.1(319mb) 

Flame 2.1(319mb)

Environmental Variables:
Device: Flame Master (319mb)
Build ID: 20140903000204
Gaia: fbb297c39aab5f17b179533d2a9a6c5166b2c197
Gecko: fb5e796da813
Version: 34.0a2 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

STR:
1: Launch any app 
2: Verify that there are no unnecessary empty spaces

Actual Result: No unnecessary empty spaces can be seen and no application seems to be squished
QA Whiteboard: [COM=Gaia::Contacts][QAnalyst-Triage+] → [COM=Gaia::Contacts][QAnalyst-Triage?]
Flags: needinfo?(ktucker)
(In reply to Carrie Wang [:carrie] from comment #8)
> For the empty space issue in Contacts, we think that might be the the
> default photos for those contacts who don't have profile pictures. The
> visual team has been working on this and from comment 3, seems like it will
> not happen in 2.1. Hence, I don't think we have any spec yet.
> 
> The other user story (the actionable fields) has similar situation and I've
> done some spec to improve it. Please check the meta bug 1043166. I think we
> can focus this one in 2.1 since it's more about interaction and only
> happening in Contacts APP. Thanks!

 I have tested and I have seen this bug related to contact application


1062789 - [Contacts] Remove button isn't correctly visible when add/edit contact
1062809 - [Contacts] Strange icon shown in the ICE Contact list when the Contact doesn't have picture
Please ignore comment 19

1)Contacts without images attached to them default properly to have the randomized blue icon with the first letter of their name, or the "#" shown, whether it is a favorite contact or not.

2) App space seems to be fixed so the apps look tighter and cleaner
__________________________________________________________________________

I am unable to verify this bug as fixed based on these issues:

3)Incoming, and outgoing calls do not show the blue background, they appear with the default firefox 
background still

4) Default country, and date are not set when adding new contact as stated here https://bugzilla.mozilla.org/show_bug.cgi?id=1043166#c4
Status: VERIFIED → RESOLVED
Closed: 6 years ago6 years ago
Flags: needinfo?(ktucker)
Hello wilfred, are issues 3) and 4) from comment 21 expected? or do they need to be bugged and blocking this bug verification?
Flags: needinfo?(wmathanaraj)
(In reply to Derek Harris [:DerekH] from comment #22)
> Hello wilfred, are issues 3) and 4) from comment 21 expected? or do they
> need to be bugged and blocking this bug verification?

Moving this to UX to see if a UX designer can confirm if the behavior above is expected or not.
Flags: needinfo?(wmathanaraj) → needinfo?(firefoxos-ux-bugzilla)
Flagging Carrie and Fang to verify interaction and visual design as observed on latest builds, on device. Please update as to whether what you see on device does or does not match your specs and visuals.
Flags: needinfo?(fshih)
Flags: needinfo?(firefoxos-ux-bugzilla)
Flags: needinfo?(cawang)
QA Whiteboard: [COM=Gaia::Contacts][QAnalyst-Triage?] → [COM=Gaia::Contacts][QAnalyst-Triage?][verification-needs-input]
> 4) Default country, and date are not set when adding new contact as stated
> here https://bugzilla.mozilla.org/show_bug.cgi?id=1043166#c4

From the latest build, the default country and date are still not match with the latest visual spec. Thanks!
Flags: needinfo?(fshih)
(In reply to Derek Harris [:DerekH] from comment #21)

> 3)Incoming, and outgoing calls do not show the blue background, they appear
> with the default firefox 
> background still

Hi Derek,
Yes, Incoming and Outgoing calls are still using default firefox wallpaper for 2.1.(when contact photo is missing)
But it should use the same imagery for the UI consistency. I will file a bug and hope to fix it in the future.
Thank you!
Flags: needinfo?(cawang)
Derek - Do we have bugs on file for issues you mentioned?
Flags: needinfo?(dharris)
Yes we do,bug 1063060 has been filed for Country and Date not being set by default, and bug 1065629 has been filed for the incoming/outgoing calls having the default firefox background, instead of the blue background.

Verifying this bug as fixed due to neither of the bugs mentioned above being blockers, and the rest of the features being implemented, as mentioned in comment 21.
Status: RESOLVED → VERIFIED
QA Whiteboard: [COM=Gaia::Contacts][QAnalyst-Triage?][verification-needs-input] → [COM=Gaia::Contacts][QAnalyst-Triage?]
Flags: needinfo?(dharris) → needinfo?(ktucker)
Verified for Flame 2.1 (319mb) and Flame 2.2 (319mb)(master)

- Contacts without images attached to them default properly to have the randomized blue icon with the first letter of their name, or the "#" shown, whether it is a favorite contact or not.

- App space seems to be fixed so the apps look tighter and cleaner


Flame 2.2

Environmental Variables:
Device: Flame Master (319mb)
BuildID: 20140910040203
Gaia: 8e02f689b0fc39cb6ccdc22d02ed7e219c58faa7
Gecko: 152ef25e89ae
Version: 35.0a1 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0


Flame 2.1

Environmental Variables:
Device: Flame 2.1
BuildID: 20140910000202 (319mb)
Gaia: 79dc972d637ff5ef7667b231e93118b4ed83ba9c
Gecko: 0890010015a2
Version: 34.0a2 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [COM=Gaia::Contacts][QAnalyst-Triage?] → [COM=Gaia::Contacts][QAnalyst-Triage+]
Flags: needinfo?(ktucker)
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.