Closed Bug 1026791 Opened 7 years ago Closed 3 years ago

SUMO: Need Support Content for Find My Device

Categories

(Firefox OS Graveyard :: FindMyDevice, defect)

All
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: elan, Unassigned)

References

Details

As of Firefox OS 2.0, Users will have the option to enable 'Find My Device' which will allow them to locate, play sound, send note, set lock screen, and remote wipe their device in the event it is lost or stolen. 

Find My Device uses Firefox Accounts for authentication and we are neighbors in the Gaia Settings App. You will also see Find My Device presented in FTU in the Firefox Account screens. 

Feel free to Need Info :elan with next steps.
As we are working through to feature complete there are a few things we'd like to suggest for inclusion:
- Compat with other web browsers (which ones work with https://find.mozilla.com)
- A couple of nuances with lockscreen interaction can be seen, here, we may or may not resolve this interaction prior to shipping but FYI: 
https://bugzilla.mozilla.org/show_bug.cgi?id=1030448#c7
FMD will try to apply the latest, user provided lock code to the device as soon as possible. Since a device may be unavailable for some period, if a user supplies different passcodes there is a chance that a user has retrieved a device before it has received the very latest lock code command. In that case, getting the phone back into network range will allow the device to "catch up" on commands. 

Since using many different passcodes can lead to confusion (both for you and the device), the user is encouraged to use a consistent, new lock code rather than vary them for each attempt.
Hi, I'm the content manager for SUMO. I'd be happy to get an article ready once "Find My Device" is feature complete.

How do we want to serve the content? Will there be a link to the article within the UI?
ni for Michael for Comment 3.
Flags: needinfo?(mtreese)
(In reply to Joni Savage from comment #3)
> Hi, I'm the content manager for SUMO. I'd be happy to get an article ready
> once "Find My Device" is feature complete.
> 
> How do we want to serve the content? Will there be a link to the article
> within the UI?

Joni: FMD is feature complete - we should try to get an article up so at least people understand how the feature works. I can help with that effort if you need information.
Marcia, hi. I've written a draft here: https://support.mozilla.org/kb/find-my-device-how-locate-lost-firefox-os-device

Please use this URL if you need to link to this article.

The article isn't complete yet - I was hoping to get the following details from you:

1. How long does it take to find a device? I tried twice and it took me ~2 hours each time. Is that expected?
2. If I enter the wrong email address while creating a new Firefox Account through FMD, there's no way for me to cancel the confirmation step. Or is there? I reset my phone instead.
3. When you use FMD to ring the device, how do you silence the device when you've found it?
4. If a device is turned off, can you still make it ring through the FMD site?
5. Does the phone need a SIM card in order to use FMD?

I can test for the last three items, but I thought I'd check with you first while waiting for the FMD site to load.

Thanks.
Joni
Flags: needinfo?(mozillamarcia.knous)
(In reply to Joni Savage from comment #6)
> Marcia, hi. I've written a draft here:
> https://support.mozilla.org/kb/find-my-device-how-locate-lost-firefox-os-
> device
> 
> Please use this URL if you need to link to this article.
> 
> The article isn't complete yet - I was hoping to get the following details
> from you:
> 
> 1. How long does it take to find a device? I tried twice and it took me ~2
> hours each time. Is that expected?
> 2. If I enter the wrong email address while creating a new Firefox Account
> through FMD, there's no way for me to cancel the confirmation step. Or is
> there? I reset my phone instead.
> 3. When you use FMD to ring the device, how do you silence the device when
> you've found it?
> 4. If a device is turned off, can you still make it ring through the FMD
> site?
> 5. Does the phone need a SIM card in order to use FMD?
> 
> I can test for the last three items, but I thought I'd check with you first
> while waiting for the FMD site to load.
> 
> Thanks.
> Joni

Joni: 

(1) It shouldn't take 2 hours to find the device, for me it happens within minutes (we can work offline to see why this is happening and get a bug on file). I suggest not adding anything about how long it takes in the article because there are many factors that will influence this.

(2) If you enter the incorrect email, you should be able use the "back" button and correct it before proceeding. As you proceed along, you can still correct things by tapping the "x" at the upper left hand corner of the screen. If you get all the way through to the end to the confirmation screen, there should be a red button which says "Cancel account confirmation." If you hit the button you can start all over.

In the case where you confirm the email on find.firefox.com, then you would have to reset your phone the way it stands now. We can check with the FX Account team to see if that will change.

(3) To silence the ring, you should be able to use the volume down button. It is expected the it will be at max volume when it starts ringing.

(4) If device is turned off, when you turn it on the ring command is queued so eventually it will start ringing when the phone is powered on.

(5) Yes, it works without a SIM if you are connected to wifi.
Flags: needinfo?(mozillamarcia.knous)
Duplicate of this bug: 1068197
Flags: needinfo?(mtreese)
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.