[Rocketbar] Rocketbar search for Marketplace will show 2 install Marketplace with different icons

VERIFIED FIXED in 2014-08-26

Status

Marketplace
General
P3
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: nhirata, Assigned: clouserw)

Tracking

Avenir
2014-08-26
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(b2g-v2.0 affected)

Details

(Whiteboard: [2.0-flame-test-run-3])

Attachments

(2 attachments)

Created attachment 8441850 [details]
2014-06-17-19-34-45.png

1. tap in the rocketbar
2. type in "Marketplac" (don't hit return
3. look at the results after it loads

Expected: only one marketplace
Actual: two marketplaces

Note:
Gaia      0f254c92bc44d614ae56a855f18a895a7e4703ad
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/7f309a3a4d3d
BuildID   20140617000201
Version   32.0a2
ro.build.version.incremental=108
ro.build.date=Tue Jun 10 19:40:40 CST 2014
Flame
We need more info here. When you select each install marketplace link, what marketplace app details page loads? I'm trying to understand if this is a bug about duplicate marketplace download suggestions or an issue with different marketplaces that can be installed off of prod.
Blocks: 1015336
Keywords: qawanted

Updated

4 years ago
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking?]
Interesting. The marketplace now has two different applications, one being a fully packaged version. It seems very confusing, I'm not sure why they would take that approach. It's also possible that they've changed the manifestURL to no longer match the manifestURL on the phone.

Seems like a marketplace bug?
Component: Gaia::Search → General
Product: Firefox OS → Marketplace
Version: unspecified → Avenir
Oh - I know what the problem is here. We're seeing the Tarako marketplace & the non-Tarako marketplace in the search results. That means we have two bugs here:

1. The Tarako marketplace shouldn't show up on non-Tarako devices
2. Rocketbar isn't recognizing that marketplace is already installed on device & still shows a marketplace download suggestion

[1] is likely the focus of this bug. I'll open a separate bug for [2].
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking?]
Keywords: qawanted
Opened bug 1027214 to track [2].

Updated

4 years ago
No longer blocks: 1015336
Component: General → Gaia::Search
Product: Marketplace → Firefox OS
Version: Avenir → unspecified
Sorry, moved the wrong bug.
Component: Gaia::Search → General
Product: Firefox OS → Marketplace
Version: unspecified → Avenir
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1027214
(Assignee)

Comment 7

4 years ago
Hidden app support is landing in bug 1006816.  The plan is to hide these after that lands.
Depends on: 1006816

Comment 8

4 years ago
I wonder if the mismatched install icon itself will be updated to match the round frame? I imagine that it’d be an easy fix (could be wrong).
(Assignee)

Comment 9

4 years ago
(In reply to Bram Pitoyo [:bram] from comment #8)
> I wonder if the mismatched install icon itself will be updated to match the
> round frame? I imagine that it’d be an easy fix (could be wrong).

Follow along at https://bugzilla.mozilla.org/show_bug.cgi?id=975535#c77 for more info on that.
(Assignee)

Updated

4 years ago
Priority: -- → P3
Duplicate of this bug: 1047653
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Whiteboard: [2.0-flame-test-run-3]
(Assignee)

Comment 11

4 years ago
Let us know if there is a hard deadline for this.  Hidden app support got backed out of last week's push due to a couple errors.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
(Assignee)

Comment 12

4 years ago
This is fixed as of today.  Thanks for your patience.
Assignee: nobody → clouserw
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2014-08-26

Comment 13

4 years ago
Verified as fixed in FF OS 2.1 (Flame)
Attaching postfix screenshot.
Closing bug.
Status: RESOLVED → VERIFIED

Comment 14

4 years ago
Created attachment 8481173 [details]
marketplace rocketbar.png
You need to log in before you can comment on or make changes to this bug.