If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Timeout calling forget_all_networks

RESOLVED WONTFIX

Status

Firefox OS
Gaia::UI Tests
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: Francisco J Cano, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8441912 [details]
logcat for the execution of the test

When executing GaiaTestCase setUp, sometimes there is a timeout in the call to forget_all_networks, with no apparent reason.

Device: Hamachi.
Gaia version: v1.3 (last commit): 7f361e67aa65e40adb2233ab247ebd0f142cfbf1

Error stack trace:
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/marionette_client_mozilla_b2g28_v1_3-0.1-py2.7.egg/marionette/marionette_test.py", line 145, in run
    self.setUp()
  File "/home/owd/automationTmp/owd-obcertification/owd_test_cases/tests/BROWSER/test_BRWSRASYNC001a.py", line 39, in setUp
    GaiaTestCase.setUp(self)
  File "/home/owd/gaia/tests/python/gaia-ui-tests/gaiatest/gaia_test.py", line 814, in setUp
    self.cleanup_gaia(full_reset=True)
  File "/home/owd/gaia/tests/python/gaia-ui-tests/gaiatest/gaia_test.py", line 870, in cleanup_gaia
    self.data_layer.forget_all_networks()
  File "/home/owd/gaia/tests/python/gaia-ui-tests/gaiatest/gaia_test.py", line 338, in forget_all_networks
    self.marionette.execute_async_script('return GaiaDataLayer.forgetAllNetworks()')
  File "/usr/local/lib/python2.7/dist-packages/marionette_client_mozilla_b2g28_v1_3-0.1-py2.7.egg/marionette/marionette.py", line 1156, in execute_async_script
    filename=os.path.basename(frame[0]))
  File "/usr/local/lib/python2.7/dist-packages/marionette_client_mozilla_b2g28_v1_3-0.1-py2.7.egg/marionette/marionette.py", line 612, in _send_message
    self._handle_error(response)
  File "/usr/local/lib/python2.7/dist-packages/marionette_client_mozilla_b2g28_v1_3-0.1-py2.7.egg/marionette/marionette.py", line 661, in _handle_error
    raise ScriptTimeoutException(message=message, status=status, stacktrace=stacktrace)
ScriptTimeoutException: ScriptTimeoutException: timed out
TEST-UNEXPECTED-FAIL | test_BRWSRASYNC001a.py test_BRWSRASYNC001a.test_main.test_run |
Component: General → Gaia::System
Unsure this is actually a real gaia bug or a test bug, so clearing the nom.
blocking-b2g: 2.0? → ---
Component: Gaia::System → Gaia::UI Tests

Comment 2

3 years ago
I could not reproduce this locally, and I run the test over 70 times.

Build:

Gaia      46cd188fdda2397d2b8f3303a184dcd52952e2b2                         
Gecko     https://hg.mozilla.org/mozilla-central/rev/e032c429908b          
BuildID   20140715040206                                                   
Version   33.0a1                                                           
ro.build.version.incremental=94                                            
ro.build.date=Tue May 20 09:29:20 CST 2014                                 
B1TC200110G0
We don't have connection issues any more.

Closing this bug
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.