[B2G][Email] Edit button does not gray out when the folder is empty

VERIFIED FIXED in Firefox OS v2.0

Status

Firefox OS
Gaia::E-Mail
P3
normal
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: edchen, Assigned: robert.sajdok)

Tracking

({regression})

unspecified
2.0 S5 (4july)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 verified)

Details

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
Created attachment 8441923 [details]
Screenshot

[Environment]
Gaia      2402076e6299ab36f492eab17795478c9d2a7ad7
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/c41d7012974e
BuildID   20140617160202
Version   32.0a2
ro.build.version.incremental=94
ro.build.date=Tue May 20 09:29:20 CST 2014

[STR]
1. Set up a mail account 
(mozillaqa1/5678Tyui)
2. Make sure the inbox folder (or others folder) is empty
3. The edit button has not gray out

[Actual result]
The edit button has not gray out

[Expected result]
The edit button should be gray out

[Attachment]
Screenshot
(Reporter)

Updated

4 years ago
blocking-b2g: --- → 2.0?
qawanted to see if there an underlying functional issue as well, which makes more of a blocking case? What happens if you click the edit button ?
Keywords: qawanted
(Assignee)

Updated

4 years ago
Assignee: nobody → robert.sajdok
(Assignee)

Comment 2

4 years ago
Created attachment 8444091 [details] [review]
Proposed fix.
Attachment #8444091 - Flags: review?(jrburke)
When the user taps the edit button on an empty email folder, the user sees the edit screen with no emails but is able to tap the buttons at the bottom which take the user out of edit mode.

This bug DOES repro on: Flame 2.1 Master, Flame 2.0, Flame 1.4, 

Actual Result: The edit button is active when no emails exist in an email folder.

Environmental Variables:
Device: Flame 2.1
Build ID: 20140620094247
Gaia: bd5065ced020014df5fd45259fba1ac32d65673b
Gecko: 892d7a8eda45
Version: 33.0a1 (2.1)
Firmware Version: v121-2
--------------------------------------------------
Environmental Variables:
Device: Flame 2.0
Build ID: 20140620101046
Gaia: 27f07f479e696af304d52e5fdd654317baa8c17d
Gecko: 606653d5d01d
Version: 32.0a2 (2.0)
Firmware Version: v121-2
---------------------------------------------------
Environmental Variables:
Device: Flame 1.4
Build ID: 20140620000201
Gaia: 3419a1f68aaf64a0688685bce42d4173b6125597
Gecko: d9c755c8055f
Version: 30.0 (1.4)
Firmware Version: v121-2
--------------------------------------------------
Environmental Variables:
Device: Flame 1.3
Build ID: 20140610200025
Gaia: e106a3f4a14eb8d4e10348efac7ae6dea2c24657
Gecko: b637b0677e15318dcce703f0358b397e09b018af
Version: 28.0 (1.3)
Firmware Version: v121-2
--------------------------------------------------
Environmental Variables:
Device: Open_C Master
Build ID: 20140620094247
Gaia: bd5065ced020014df5fd45259fba1ac32d65673b
Gecko: 892d7a8eda45
Version: 33.0a1 (Master)
Firmware Version: P821A10V1.0.0B06_LOG_DL
--------------------------------------------------
Environmental Variables:
Device: Open_C 2.0
Build ID: 20140620101046
Gaia: 27f07f479e696af304d52e5fdd654317baa8c17d
Gecko: 606653d5d01d
Version: 32.0a2 (2.0)
Firmware Version: P821A10V1.0.0B06_LOG_DL
------------------------------------------------
Environmental Variables:
Device: Open_C 1.4
Build ID: 20140620000201
Gaia: 3419a1f68aaf64a0688685bce42d4173b6125597
Gecko: d9c755c8055f
Version: 30.0 (1.4)
Firmware Version: P821A10V1.0.0B06_LOG_DL
------------------------------------------------
Environmental Variables:
Device: Buri Master
Build ID: 20140620094247
Gaia: bd5065ced020014df5fd45259fba1ac32d65673b
Gecko: 892d7a8eda45
Version: 33.0a1 (Master)
Firmware Version: v1.2device.cfg
------------------------------------------------
Environmental Variables:
Device: Buri 2.0
Build ID: 20140620145242
Gaia: 751617235a44ca9c2a641b751de00ff48136657e
Gecko: e72b00065ebe
Version: 32.0a2 (2.0)
Firmware Version: v1.2device.cfg
------------------------------------------------
Environmental Variables:
Device: Buri 1.4
Build ID: 20140619125100
Gaia: 3419a1f68aaf64a0688685bce42d4173b6125597
Gecko: d9c755c8055f
Version: 30.0 (1.4)
Firmware Version: v1.2device.cfg

------------------------------------------------
------------------------------------------------


This Bug does NOT repro on: Flame Base v121-2, OpenC Base, Buri 1.3

Actual Results: The Edit button is greyed out when no emails are present.

Environmental Variables:
Device: Flame 1.3
Build ID: 20140610200025
Gaia: e106a3f4a14eb8d4e10348efac7ae6dea2c24657
Gecko: b637b0677e15318dcce703f0358b397e09b018af
Version: 28.0 (1.3)
Firmware Version: v121-2
-------------------------------------------------
Environmental Variables:
Device: Open_C 1.3
Build ID: 20140527120838
Gaia: Unknown Git commit; build date shown here.
Gecko: Unknown
Version: 28.0 (1.3)
Firmware Version: P821A10V1.0.0B06_LOG_DL
-------------------------------------------------
Environmental Variables:
Device: Buri 1.3
Build ID: 20140619045734
Gaia: 5f4211ac94cc158a07269d0a0beca3c7937d78cc
Gecko: ace309b4ec92
Version: 28.0 (1.3)
Firmware Version: v1.2device.cfg
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted → regression
QA Contact: croesch
QA-Wanted Report - Holding of on adding Regression-window-wanted until it is decided if this is a blocker or not. 

Issue is not high-visibility (most users will not attempt to edit and empty email box) and low-impact ("but is able to tap the buttons at the bottom which take the user out of edit mode.")
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
*Holding OFF

Updated

4 years ago
Duplicate of this bug: 1007313
Target Milestone: --- → 2.0 S5 (4july)
blocking-b2g: 2.0? → 2.0+

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+]
Keywords: regressionwindow-wanted
QA Contact: croesch → pcheng
Created attachment 8445363 [details]
Comparison screenshot - left is from Last Working build, right is from First Broken build

This issue occurs on the earliest Buri tinderbox build that we have available (1/23), therefore the window was found using Nightly builds.

Nightly regression window:

Last Working Environmental Variables:
Device: Buri
Build ID: 20140109040203
Gaia: 47206ac66b084c6f6c4503a3b10d0e0760df2b6f
Gecko: 9409405e0739
Version: 29.0a1 (Master)
Firmware Version: v1.2device.cfg

First Broken Environmental Variables:
Device: Buri
Build ID: 20140110040206
Gaia: f400efc804366c7b7cf5476d1d5d325e6651ee71
Gecko: 37516445a0b5
Version: 29.0a1 (Master)
Firmware Version: v1.2device.cfg

Last Working Gaia / First Broken Gecko: Issue Does NOT reproduce
Gaia: 47206ac66b084c6f6c4503a3b10d0e0760df2b6f
Gecko: 37516445a0b5

Last Working Gecko / First Broken Gaia: Issue DOES reproduce
Gaia: f400efc804366c7b7cf5476d1d5d325e6651ee71
Gecko: 9409405e0739

Gaia Pushlog:
https://github.com/mozilla-b2g/gaia/compare/47206ac66b084c6f6c4503a3b10d0e0760df2b6f...f400efc804366c7b7cf5476d1d5d325e6651ee71

Note:
This issue occurs as soon as the new email bottom toolbar UI is implemented. I've attached screenshots from my last working and first broken builds for comparison.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Comment on attachment 8444091 [details] [review]
Proposed fix.

Left a comment with two items to address. Once those are addressed and the commit is rebased/squashed to one commit, flip r? back to me, and it should be easy to review and land. Thank you!
Attachment #8444091 - Flags: review?(jrburke)
(Assignee)

Updated

4 years ago
Attachment #8444091 - Flags: review?(jrburke)
Comment on attachment 8444091 [details] [review]
Proposed fix.

Great, thank you!
Attachment #8444091 - Flags: review?(jrburke) → review+
Merged in master:
https://github.com/mozilla-b2g/gaia/commit/89be34c2009f33d8044e14c1f52000ff30a8c004

from pull request:
https://github.com/mozilla-b2g/gaia/pull/20860
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
v2.0: https://github.com/mozilla-b2g/gaia/commit/b4448699dd29983e420a7cbb407e9f5b9c0a371f
status-b2g-v2.0: --- → fixed
status-b2g-v2.1: --- → fixed
(Reporter)

Comment 12

4 years ago
[Environment]
Gaia      2248c0367661db9332f70f37055e1a8176f5f612
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/44d31566a3a6
BuildID   20140629160202
Version   32.0a2
ro.build.version.incremental=108
ro.build.date=Tue Jun 10 19:40:40 CST 2014

[Result]
Pass
Status: RESOLVED → VERIFIED

Updated

3 years ago
status-b2g-v2.0: fixed → verified
status-b2g-v2.1: fixed → verified

Comment 13

3 years ago
Created attachment 8528893 [details]
VIDEO0051.mp4

This issue has been successfully verified on Flame 2.0:
Gaia-Rev        99e4594c66aa3738d58b0cb44bd885a87a063b6e
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/f91abc6127d9
Build-ID        20141125000201
Version         32.0
Device-Name     flame
FW-Release      4.4.2


This issue has been successfully verified on Flame 2.1:
Gaia-Rev        1bdd49770e2cb7a7321e6202c9bf036ab5d8f200
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/db893274d9a6
Build-ID        20141125001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
You need to log in before you can comment on or make changes to this bug.