With Outook Express running, Mozilla fails to set itself as default email client.

VERIFIED WORKSFORME

Status

MailNews Core
Simple MAPI
P4
normal
VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: Trix Supremo, Assigned: Srilatha Moturi)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
If Outlook Express is running and you launch mozilla and select it to be the
default email client, mozilla fails to become the default email client(prefs
remains disabled).  If mozilla is running and you launch Outlook Express you can
successfully select it as the default email client.

DIRECTIONS:
1. Launch Outlook Express and select it as your default email client.
2. Launch Mozilla, and in Edit|Preferences|Mail & Newsgroups, select Mozilla to
be the default email client.
3. Close and reopen Mozilla and go back to pref panel.

ACTUAL:
Mozilla is still not the default email client. the MAPI32.DLL used is still the
smart .DLL used by Outlook Express.

EXPECTED:Expect the same behavior with Outlook Express.

Updated

17 years ago
Priority: -- → P4

Updated

17 years ago
Keywords: nsbranch-

Comment 1

17 years ago
Mark as depedent to meta bug 103807

Updated

17 years ago
Blocks: 103807

Comment 2

17 years ago
Question:  Once the user exits OE, s/he will be able to check this setting in
Netscape/Mozilla, right?  (ie. there is not a mismatch with the dll and the
setting shown in the preference)

(Reporter)

Comment 3

17 years ago
hi lisa,

that is correct, if you close express and then you launch mozilla to change the
default email status, that change is saved. my comparison was to express'
behavior when both express and mozilla mail are both launched and you change the
default email status in express, which express does end up saving the settings.
(Reporter)

Comment 4

17 years ago
one other note, in the case with Express and Mozilla Mail, both work with the
same MAPI32.DLL which looks to the registry to determine which is the default
email client. so in this case there is no file changing/swapping going on, but
what actually occurs is that registry settings are changing.

[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail]
@="Netscape 6"

to 

[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail]
@="Outlook Express"


and back again.
(Assignee)

Comment 5

17 years ago
Not able to reproduce with today's 0.9.4 build.
Marking this as Resolved Worksforme
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

17 years ago
reopening so that I can mark this as worksforme
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 7

17 years ago
Now really marking as worksforme
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

17 years ago
marking verified
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.