Callscreen: DTMF tone does is not being sent (also not audible)

RESOLVED DUPLICATE of bug 1026081

Status

Firefox OS
Gaia::Dialer
RESOLVED DUPLICATE of bug 1026081
4 years ago
4 years ago

People

(Reporter: freddyb, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

STR:
1) Call voicemail
2) Open the number pad on the call screen
3) Press a number

Result:
Nothing is being heard, nothing is being sent.
Error output in logcat:
E/GeckoConsole(  290): [JavaScript Error: "TypeError: this._phoneNumber is undefined" {file: "app://callscreen.gaiamobile.org/gaia_build_defer_index.js" line: 110}]

Expected result:
Send and play the corresponding tone.
:gerard-majax reproduced and said this error is older than dfc4703bb81d1fa4f2087a1a6124b47a80a5d1de (Jun 15)
That's quite blocker for at least 2.1.
blocking-b2g: --- → 2.1?
> E/GeckoConsole( 1844): [JavaScript Error: "TypeError: this._phoneNumber is undefined" {file: "app://callscreen.gaiamobile.org/shared/js/dialer/keypad.js" line: 536}]

So far it seems not to affect 2.0.

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1026081

Updated

4 years ago
blocking-b2g: 2.1? → ---
You need to log in before you can comment on or make changes to this bug.