Intermittent jsreftest.html?test=test262/ch11/11.4/11.4.1/11.4.1-4.a-6.js | application crashed [@ nsInputStreamPump::OnStateStop()] | Assertion failure: NS_IsMainThread() (OnStateStop should only be called on the main thread.), at c:\builds\moz2_slave\m

RESOLVED DUPLICATE of bug 1026951

Status

()

Core
General
RESOLVED DUPLICATE of bug 1026951
4 years ago
4 years ago

People

(Reporter: Tomcat, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

4 years ago
Windows 7 32-bit mozilla-inbound debug test jsreftest on 2014-06-17 23:35:58 PDT for push 109ded3295f8

slave: t-w732-ix-015

https://tbpl.mozilla.org/php/getParsedLog.php?id=41936482&tree=Mozilla-Inbound

Assertion failure: NS_IsMainThread() (OnStateStop should only be called on the main thread.), at c:\builds\moz2_slave\m-in-w32-d-0000000000000000000\build\netwerk\base\src\nsInputStreamPump.cpp:676
TEST-UNEXPECTED-FAIL | file:///C:/slave/test/build/tests/jsreftest/tests/jsreftest.html?test=test262/ch11/11.4/11.4.1/11.4.1-4.a-6.js | Exited with code -2147483645 during test run
PROCESS-CRASH | file:///C:/slave/test/build/tests/jsreftest/tests/jsreftest.html?test=test262/ch11/11.4/11.4.1/11.4.1-4.a-6.js | application crashed [@ nsInputStreamPump::OnStateStop()]

23:59:51  WARNING -  PROCESS-CRASH | file:///C:/slave/test/build/tests/jsreftest/tests/jsreftest.html?test=test262/ch11/11.4/11.4.1/11.4.1-4.a-6.js | application crashed [@ nsInputStreamPump::OnStateStop()]
23:59:51     INFO -  Crash dump filename: c:\users\cltbld\appdata\local\temp\tmpjybwhy.mozrunner\minidumps\cc3ce872-2a6c-44d3-99b6-f6d019beedf5.dmp
23:59:51     INFO -  Operating system: Windows NT
23:59:51     INFO -                    6.1.7601 Service Pack 1
23:59:51     INFO -  CPU: x86
23:59:51     INFO -       GenuineIntel family 6 model 30 stepping 5
23:59:51     INFO -       8 CPUs
23:59:51     INFO -  Crash reason:  EXCEPTION_BREAKPOINT
23:59:51     INFO -  Crash address: 0x63ebd665
23:59:51     INFO -  Thread 25 (crashed)
23:59:51     INFO -   0  xul.dll!nsInputStreamPump::OnStateStop() [nsInputStreamPump.cpp:109ded3295f8 : 676 + 0x20]
23:59:51     INFO -      eip = 0x63ebd665   esp = 0x125bf704   ebp = 0x125bf71c   ebx = 0x0c151cf0
23:59:51     INFO -      esi = 0x0c151cf0   edi = 0x00000003   eax = 0x00000000   ecx = 0x6b1cff12
23:59:51     INFO -      edx = 0x771a7094   efl = 0x00000212
23:59:51     INFO -      Found by: given as instruction pointer in context
23:59:51     INFO -   1  xul.dll!nsInputStreamPump::OnInputStreamReady(nsIAsyncInputStream *) [nsInputStreamPump.cpp:109ded3295f8 : 440 + 0xc]
23:59:51     INFO -      eip = 0x63ebdbb1   esp = 0x125bf724   ebp = 0x125bf73c
23:59:51     INFO -      Found by: call frame info
23:59:51     INFO -   2  xul.dll!nsInputStreamReadyEvent::Run() [nsStreamUtils.cpp:109ded3295f8 : 88 + 0x10]
23:59:51     INFO -      eip = 0x63e35f1c   esp = 0x125bf744   ebp = 0x125bf754
23:59:51     INFO -      Found by: call frame info
23:59:51     INFO -   3  xul.dll!nsThread::ProcessNextEvent(bool,bool *) [nsThread.cpp:109ded3295f8 : 766 + 0xd]
23:59:51     INFO -      eip = 0x63e4e694   esp = 0x125bf75c   ebp = 0x125bf7b8
23:59:51     INFO -      Found by: call frame info
23:59:51     INFO -   4  xul.dll!NS_ProcessNextEvent(nsIThread *,bool) [nsThreadUtils.cpp:109ded3295f8 : 263 + 0xc]
23:59:51     INFO -      eip = 0x63de6066   esp = 0x125bf7c0   ebp = 0x125bf7cc
23:59:51     INFO -      Found by: call frame info
23:59:51     INFO -   5  xul.dll!mozilla::ipc::MessagePumpForNonMainThreads::Run(base::MessagePump::Delegate *) [MessagePump.cpp:109ded3295f8 : 336 + 0x9]
23:59:51     INFO -      eip = 0x64097c7e   esp = 0x125bf7d4   ebp = 0x125bf7f8
23:59:51     INFO -      Found by: call frame info
23:59:51     INFO -   6  xul.dll!MessageLoop::RunInternal() [message_loop.cc:109ded3295f8 : 229 + 0x8]
23:59:51     INFO -      eip = 0x64067b9f   esp = 0x125bf800   ebp = 0x125bf818
23:59:51     INFO -      Found by: call frame info
23:59:51     INFO -   7  xul.dll!MessageLoop::RunHandler() [message_loop.cc:109ded3295f8 : 222 + 0x4]
23:59:51     INFO -      eip = 0x64069c64   esp = 0x125bf820   ebp = 0x125bf84c
23:59:51     INFO -      Found by: call frame info
23:59:51     INFO -   8  xul.dll!MessageLoop::Run() [message_loop.cc:109ded3295f8 : 196 + 0x6]
23:59:51     INFO -      eip = 0x6406a2c4   esp = 0x125bf854   ebp = 0x125bf86c
23:59:51     INFO -      Found by: call frame info
23:59:51     INFO -   9  xul.dll!nsThread::ThreadFunc(void *) [nsThread.cpp:109ded3295f8 : 346 + 0x11]
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
See Also: → bug 1026951
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Blocks: 1039536
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Updated

4 years ago
Duplicate of this bug: 1036429

Updated

4 years ago
Duplicate of this bug: 1038710

Updated

4 years ago
Summary: Intermittent jsreftest.html?test=test262/ch11/11.4/11.4.1/11.4.1-4.a-6.js | application crashed [@ nsInputStreamPump::OnStateStop()] | Assertion failure: NS_IsMainThread() (OnStateStop should only be called on the main thread.), at c:\builds\moz2_slave\m → Intermittent reftest/crashtest/jsreftest "Assertion failure: NS_IsMainThread() (OnStateStop should only be called on the main thread.), at nsInputStreamPump.cpp:676" [@ nsInputStreamPump::OnStateStop()]
Bah, picked the wrong bug to dupe against - bug 1026951 has more occurrences, so duping against that.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: intermittent-failure
Resolution: --- → DUPLICATE
Summary: Intermittent reftest/crashtest/jsreftest "Assertion failure: NS_IsMainThread() (OnStateStop should only be called on the main thread.), at nsInputStreamPump.cpp:676" [@ nsInputStreamPump::OnStateStop()] → Intermittent jsreftest.html?test=test262/ch11/11.4/11.4.1/11.4.1-4.a-6.js | application crashed [@ nsInputStreamPump::OnStateStop()] | Assertion failure: NS_IsMainThread() (OnStateStop should only be called on the main thread.), at c:\builds\moz2_slave\m
Duplicate of bug: 1026951
You need to log in before you can comment on or make changes to this bug.