Closed Bug 1027034 Opened 6 years ago Closed 6 years ago

Failure to build with Gtk3 < 3.5.12.

Categories

(Core :: Widget: Gtk, defect)

All
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla33

People

(Reporter: glandium, Assigned: glandium)

References

Details

Attachments

(1 file)

/builds/slave/try-l64-0000000000000000000000/build/widget/gtk/nsGtkIMModule.cpp:582:17: error: 'GtkInputPurpose' was not declared in this scope
/builds/slave/try-l64-0000000000000000000000/build/widget/gtk/nsGtkIMModule.cpp:582:33: error: expected ';' before 'purpose'
/builds/slave/try-l64-0000000000000000000000/build/widget/gtk/nsGtkIMModule.cpp:603:21: error: 'purpose' was not declared in this scope
/builds/slave/try-l64-0000000000000000000000/build/widget/gtk/nsGtkIMModule.cpp:603:31: error: 'GTK_INPUT_PURPOSE_PASSWORD' was not declared in this scope
/builds/slave/try-l64-0000000000000000000000/build/widget/gtk/nsGtkIMModule.cpp:605:21: error: 'purpose' was not declared in this scope
/builds/slave/try-l64-0000000000000000000000/build/widget/gtk/nsGtkIMModule.cpp:605:31: error: 'GTK_INPUT_PURPOSE_EMAIL' was not declared in this scope
/builds/slave/try-l64-0000000000000000000000/build/widget/gtk/nsGtkIMModule.cpp:607:21: error: 'purpose' was not declared in this scope
/builds/slave/try-l64-0000000000000000000000/build/widget/gtk/nsGtkIMModule.cpp:607:31: error: 'GTK_INPUT_PURPOSE_URL' was not declared in this scope
/builds/slave/try-l64-0000000000000000000000/build/widget/gtk/nsGtkIMModule.cpp:609:21: error: 'purpose' was not declared in this scope
/builds/slave/try-l64-0000000000000000000000/build/widget/gtk/nsGtkIMModule.cpp:609:31: error: 'GTK_INPUT_PURPOSE_PHONE' was not declared in this scope
/builds/slave/try-l64-0000000000000000000000/build/widget/gtk/nsGtkIMModule.cpp:611:21: error: 'purpose' was not declared in this scope
/builds/slave/try-l64-0000000000000000000000/build/widget/gtk/nsGtkIMModule.cpp:611:31: error: 'GTK_INPUT_PURPOSE_NUMBER' was not declared in this scope
/builds/slave/try-l64-0000000000000000000000/build/widget/gtk/nsGtkIMModule.cpp:614:56: error: 'purpose' was not declared in this scope
make[5]: *** [nsGtkIMModule.o] Error 1

The problem is that the compat wrapper that was added in bug 931378 is actually not used.
Attachment #8442059 - Flags: review?(karlt) → review+
https://hg.mozilla.org/mozilla-central/rev/48639e44baf4
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla33
Blocks: 1034064
No longer blocks: 1034064
You need to log in before you can comment on or make changes to this bug.