Failure to build with Gtk3 < 3.5.12.

RESOLVED FIXED in mozilla33

Status

()

Core
Widget: Gtk
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: glandium, Assigned: glandium)

Tracking

unspecified
mozilla33
All
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
/builds/slave/try-l64-0000000000000000000000/build/widget/gtk/nsGtkIMModule.cpp:582:17: error: 'GtkInputPurpose' was not declared in this scope
/builds/slave/try-l64-0000000000000000000000/build/widget/gtk/nsGtkIMModule.cpp:582:33: error: expected ';' before 'purpose'
/builds/slave/try-l64-0000000000000000000000/build/widget/gtk/nsGtkIMModule.cpp:603:21: error: 'purpose' was not declared in this scope
/builds/slave/try-l64-0000000000000000000000/build/widget/gtk/nsGtkIMModule.cpp:603:31: error: 'GTK_INPUT_PURPOSE_PASSWORD' was not declared in this scope
/builds/slave/try-l64-0000000000000000000000/build/widget/gtk/nsGtkIMModule.cpp:605:21: error: 'purpose' was not declared in this scope
/builds/slave/try-l64-0000000000000000000000/build/widget/gtk/nsGtkIMModule.cpp:605:31: error: 'GTK_INPUT_PURPOSE_EMAIL' was not declared in this scope
/builds/slave/try-l64-0000000000000000000000/build/widget/gtk/nsGtkIMModule.cpp:607:21: error: 'purpose' was not declared in this scope
/builds/slave/try-l64-0000000000000000000000/build/widget/gtk/nsGtkIMModule.cpp:607:31: error: 'GTK_INPUT_PURPOSE_URL' was not declared in this scope
/builds/slave/try-l64-0000000000000000000000/build/widget/gtk/nsGtkIMModule.cpp:609:21: error: 'purpose' was not declared in this scope
/builds/slave/try-l64-0000000000000000000000/build/widget/gtk/nsGtkIMModule.cpp:609:31: error: 'GTK_INPUT_PURPOSE_PHONE' was not declared in this scope
/builds/slave/try-l64-0000000000000000000000/build/widget/gtk/nsGtkIMModule.cpp:611:21: error: 'purpose' was not declared in this scope
/builds/slave/try-l64-0000000000000000000000/build/widget/gtk/nsGtkIMModule.cpp:611:31: error: 'GTK_INPUT_PURPOSE_NUMBER' was not declared in this scope
/builds/slave/try-l64-0000000000000000000000/build/widget/gtk/nsGtkIMModule.cpp:614:56: error: 'purpose' was not declared in this scope
make[5]: *** [nsGtkIMModule.o] Error 1

The problem is that the compat wrapper that was added in bug 931378 is actually not used.
(Assignee)

Comment 1

4 years ago
Created attachment 8442059 [details] [diff] [review]
Properly set up Gtk+3 compatibility headers
Attachment #8442059 - Flags: review?(karlt)
(Assignee)

Updated

4 years ago
Blocks: 1016641
Attachment #8442059 - Flags: review?(karlt) → review+

Comment 3

4 years ago
https://hg.mozilla.org/mozilla-central/rev/48639e44baf4
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla33

Updated

4 years ago
Blocks: 1034064

Updated

4 years ago
No longer blocks: 1034064
You need to log in before you can comment on or make changes to this bug.