[B2G][Flame] follow up of bug 1018335 - Keyboard is visible when resume from sleep

RESOLVED WONTFIX

Status

Firefox OS
Gaia::System::Input Mgmt
RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: whsu, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v1.4 wontfix, b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 unaffected)

Details

(Whiteboard: [FT:System-Platform])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
+++ This bug was initially created as a clone of Bug #1018335 +++

* Description:
  After the following patch lands on V1.4, I still can see that the keyboard temporarily shows on screen.
  Here is the demo video.
  - https://bug1018335.bugzilla.mozilla.org/attachment.cgi?id=8441965

* Reproduction steps:
  1. Launch the Contact app
  2. Tap "+" to edit a contact
  3. Tap the "Email" field
  4. After keyboard pops up, please press power on button to enter sleep mode
  5. Press the power on button again
  6. Quickly slide the slider bar

* Expected result:
  You can unlock locked screen and all UI works as normal

* Actual result:
  FxOS temporarily displays keyboard

* Environmental Variables:
 - Gaia      3bdd037ec1a11abebe16a5d7f6ff0d863e80bc07
 - Gecko     https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/523491fa3339
 - BuildID   20140618000203
 - Version   30.0

Updated

4 years ago
blocking-b2g: --- → 1.4?

Updated

4 years ago
Whiteboard: [2.0-flame-test-run-1], [FT:System-Platform][p=1] → [FT:System-Platform]
Rudy - QA's testing shows that the patch in bug 1018335 doesn't work. Can you backout?
blocking-b2g: 1.4? → 1.4+
Flags: needinfo?(rlu)
May I know why we create this bug, but not reopen bug 1018335 instead?
Is this because this issue only occurs on v1.4 but not on v2.0+?
Flags: needinfo?(rlu) → needinfo?(whsu)
(In reply to Rudy Lu [:rudyl] from comment #2)
> May I know why we create this bug, but not reopen bug 1018335 instead?
> Is this because this issue only occurs on v1.4 but not on v2.0+?

We can reopen if you like, but we should probably backout the patch.
(Reporter)

Comment 4

4 years ago
(In reply to Rudy Lu [:rudyl] from comment #2)
> May I know why we create this bug, but not reopen bug 1018335 instead?
> Is this because this issue only occurs on v1.4 but not on v2.0+?

Yes! you got that right, because this issue only occurs on v1.4 but not on v2.0.
We may miss some files/codes while we uplifted the patch to V1.4.
I would like to use this ticket to trace the bug status.
Also, could we have your expertise to decide whether we need to backout the patch from V1.4 or not?
Thanks so much, Rudy! :)
Flags: needinfo?(whsu)
From my point of view, the patch from bug 1018335 does work on v1.4, so for most of the time, you won't see the keyboard when resuming from sleep or after you unlocked the phone.
However, sometimes (might be graphic issue, not sure) you could still see the keyboard flickering for a short time after you unlocked the phone as the issue described.

William, could you please comment on the reproduction rate of this?
I tried this on Helix with v1.4, and I could reproduce this 1 out of about 10 times.
Flags: needinfo?(whsu)
From my test, this issue would only occur when you press the power button to lock the phone, and press it again immediately to show the lockscreen and then unlock.

I don't think this is a common case that the users would hit.
So ask to re-nominate this issue.
blocking-b2g: 1.4+ → 1.4?
(Reporter)

Comment 7

4 years ago
I submitted this bug(Bug 964986) on V1.4 while I executed keyboard fullrun.
But, I didn't nominate it because I cannot find critical user impact.
Recently, QAnalyst submitted some duplicated bugs while they executed keyboard fullrun on V2.0.
Duplicated bugs were presented. It means that the reproduction rate is high, so Bug 1018335 became a "v1.4+" bug.
Sure! We could re-nominate the bug. But... what about the uplifted patch?
Do we still keep it on the V1.4?

Also, I noticed the trigger point of this bug.
If you quickly unlock the homescreen, it will easy to reproduce.
Not sure if it relates to lockscreen because we did the lockscreen refactoring on V2.0.
So, the patch works on V2.0 but cannot work on V1.4.
Attach demo video. (WP_20140620_004.mp4)
Flags: needinfo?(whsu)
(Reporter)

Comment 8

4 years ago
Created attachment 8443260 [details]
WP_20140620_004.mp4
If the repro rate has dropped significantly from the landing of the patch, then we don't need to block on this.
blocking-b2g: 1.4? → ---
As the issue would occur on v1.4 only and this is not a blocker, will set this as wontfix.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-b2g-v1.4: --- → wontfix
status-b2g-v2.0: --- → unaffected
status-b2g-v2.1: --- → unaffected
status-b2g-v2.2: --- → unaffected
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.