Rename nsGIFDecoder2::mCurrentFrame to mCurrentFrameIndex

RESOLVED FIXED in mozilla33

Status

()

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: milan, Assigned: milan)

Tracking

32 Branch
mozilla33
x86
All
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

nsGIFDecoder2 is derived from Decoder.  Decoder has a protected imgFrame* mCurrentFrame.  nsGIFDecoder2 has int32_t mCurrentFrame.  Yes, it works, but there is no need for the confusion.  Just rename nsGIFDecoder2::mCurrentFrame to mCurrentFrameIndex instead.
Attachment #8442115 - Flags: review?(jmuizelaar) → review+
https://hg.mozilla.org/mozilla-central/rev/5e70b11b57c6
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla33
You need to log in before you can comment on or make changes to this bug.